summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2015-10-01 20:04:25 -0600
committerRyan Hill <rhill@gentoo.org>2015-10-01 20:04:25 -0600
commit368ffea03a647d0bdd09c587bff69abe694a90ba (patch)
tree2ca2c8a5704d598e8999cb1bef1d69fbad14c5f2
parentmedia-sound/mumble: Fix build with GCC 4.9. (diff)
downloadgentoo-368ffea0.tar.gz
gentoo-368ffea0.tar.bz2
gentoo-368ffea0.zip
media-sound/lame: Build files requiring SSE with SSE.
Gentoo-Bug: https://bugs.gentoo.org/542192 Package-Manager: portage-2.2.22 Signed-off-by: Ryan Hill <rhill@gentoo.org>
-rw-r--r--media-sound/lame/files/lame-3.99.5-msse.patch18
-rw-r--r--media-sound/lame/lame-3.99.5-r1.ebuild1
2 files changed, 19 insertions, 0 deletions
diff --git a/media-sound/lame/files/lame-3.99.5-msse.patch b/media-sound/lame/files/lame-3.99.5-msse.patch
new file mode 100644
index 000000000000..56608f665460
--- /dev/null
+++ b/media-sound/lame/files/lame-3.99.5-msse.patch
@@ -0,0 +1,18 @@
+https://bugs.gentoo.org/542192
+
+Description: Build xmm_quantize_sub.c with -msse
+Author: Sebastian Ramacher <sramacher@debian.org>
+Bug: http://sourceforge.net/p/lame/bugs/443/
+Bug-Debian: https://bugs.debian.org/760047
+Last-Update: 2014-08-31
+
+--- lame-3.99.5+repack1.orig/libmp3lame/vector/Makefile.am
++++ lame-3.99.5+repack1/libmp3lame/vector/Makefile.am
+@@ -20,6 +20,7 @@ xmm_sources = xmm_quantize_sub.c
+
+ if WITH_XMM
+ liblamevectorroutines_la_SOURCES = $(xmm_sources)
++liblamevectorroutines_la_CFLAGS = -msse
+ endif
+
+ noinst_HEADERS = lame_intrin.h
diff --git a/media-sound/lame/lame-3.99.5-r1.ebuild b/media-sound/lame/lame-3.99.5-r1.ebuild
index e14c0304c585..490e597ae57a 100644
--- a/media-sound/lame/lame-3.99.5-r1.ebuild
+++ b/media-sound/lame/lame-3.99.5-r1.ebuild
@@ -31,6 +31,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-3.96-ccc.patch \
"${FILESDIR}"/${PN}-3.98-gtk-path.patch \
"${FILESDIR}"/${PN}-3.99.5-tinfo.patch \
+ "${FILESDIR}"/${PN}-3.99.5-msse.patch \
"${WORKDIR}"/${P}-automake-2.12.patch
mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm