summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 09:12:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 10:12:07 +0200
commit3693ae11e0b98a94b2bf714a2d1dbd13e52e27ab (patch)
treea79dd3dd10c75f362bafd209959b586bc6165add
parentdev-python/trimesh: Bump to 3.11.2 (diff)
downloadgentoo-3693ae11.tar.gz
gentoo-3693ae11.tar.bz2
gentoo-3693ae11.zip
dev-python/botocore: Bump to 1.25.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.25.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4f8ef0435c61..2c3cd9394268 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.24.42.tar.gz 8907476 BLAKE2B 11cdce9d9c69835b1e57757d67d561f24932698dcaf9fc20e1add319889992b9c57c91ab5e9495027b9b96b6782698b29801d3f3815e8bfb47a67197c91448b5 SHA512 c7339cf03b121289eccc8dfe24c16ab28cba121ec1cd1883eaf2b29cd57b5e84d4e4b3a0bfcb8b4cbd0d213976af30630b2bda22e336edbaf208f5edd7823571
DIST botocore-1.24.46.tar.gz 8922345 BLAKE2B f9caf235e902be9e4e15e9a570e67cac328eb7e53668e7e12ba8e6caa4c9ed53e22115231d58fdf8d782ff3ab618e5485438dce7c454918a5d53341e5e5967ac SHA512 ccdbd6e6617a68f810c5491f37a6e94ffe015b30dfea8b01c2543b58c81573358b69af702df2fcf3efb7dd2c4b715e86957c4d60b8f0a0a51279e921dfe02993
DIST botocore-1.25.0.tar.gz 8925642 BLAKE2B 7f7b89e59801564284cd5e22958bb590aeb821c38682c7dd6163fd31b1c181ae67412b3d8cde351a48a63c2e762923d6bb2bb051e9a367468eb77db228e1c3ad SHA512 43f3edcd6868b37933b24486091097dd6dfc51f51773bea3e3cff1fce5eef5f8b3df6d09b8815c858f5c8d7e87e8ed14cf13f236e72c851e4f98d52ad85e4afc
+DIST botocore-1.25.1.tar.gz 8931771 BLAKE2B 6d2ba3c564104e8463ce588a0f9de47d4ecb7397ae03ddd4698b38f18617ab225676925d142ae0805467f860410addfbefbf6eed521d5142b994274c3bde7a06 SHA512 52dff81c0f7064aa1edc15aebf3e326c0b4ba1dc87667c8da6f487b1caa03a5ba3247253994139dab7d40873197d88f94e8545ffc3e2d51f26c14de27b5d6460
diff --git a/dev-python/botocore/botocore-1.25.1.ebuild b/dev-python/botocore/botocore-1.25.1.ebuild
new file mode 100644
index 000000000000..759ccf657074
--- /dev/null
+++ b/dev-python/botocore/botocore-1.25.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}