summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-25 23:47:14 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-25 23:47:14 +0100
commit36a8d49c11d6d1752bd7f182ad500abd59fc728d (patch)
treef711deb4ce815205d1119156179df3852753f5dd
parentdev-python/websocket-client: Bump to 1.3.1 (diff)
downloadgentoo-36a8d49c.tar.gz
gentoo-36a8d49c.tar.bz2
gentoo-36a8d49c.zip
dev-python/botocore: Bump to 1.24.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.24.8.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f70bde3359dd..bb7100517bd7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -11,3 +11,4 @@ DIST botocore-1.24.4.tar.gz 8775103 BLAKE2B c23256daab72fd60dbc9c3cb665816970bb1
DIST botocore-1.24.5.tar.gz 8775639 BLAKE2B 13237fb78068dcab03f33c5e13d97040520fe8538e6c626e806890bce04689af9b9a0997b0c374bd09e0ae410b4c4288e236d122c30326dab7395ada17a3dc07 SHA512 4ddb38ab4d4c777236576d806d6f611a1cc70a17f9e74f7d7a3071c51ee56354a19ba9e624c7369acb0a72b39473a8bf98b9aca4bf695286d3bf73df729172aa
DIST botocore-1.24.6.tar.gz 8777068 BLAKE2B 024a5bf4529d703c86635c836773a594b7bb9a1edb22cf40bde7b27d5b668b20708700fae46da14841a174d00953c20d79967523663c1f8e2c5faa30c63751fb SHA512 8298f53e85a0b92b7f71c25613d6fb467ec8be6de88e19f7b5c7bd979efbf1516a4bea4f3a885bde2d2cb7191a946bcfd55c4ce0ab584fd284dd71d1155dade5
DIST botocore-1.24.7.tar.gz 8798732 BLAKE2B 8ad6399e3353861e71810a80d1bdc2a03d952bdc00ef2bc6fbd0726e12a6c404f607358c0b33447c37aa031f9050bacc9d50859e6332e1f7432588a68c4e86b0 SHA512 9e37321dabc6279133cfd1a8e4c51cec41ebe262f412d789509ea5e27c8545d65883d62f2de5fc74870592e95a2676705f926516e6b6dd9935f199a5aa45e15b
+DIST botocore-1.24.8.tar.gz 8798121 BLAKE2B 4ca37ed7be0af62901bf154f75739cc7e07505a809e551884c72d5b5eed334fff1111fc6db016df522564a1f3d9b6f258e8eca96161a734711340bf880b553b5 SHA512 6ac2139694ab199313a0fb9a2f783b12de7f3915d10cba739f4758356a3b84a917c3c394954b6d82d7a62de907c6fe57a3559e2b9a625bb0479e7bacd31d21cc
diff --git a/dev-python/botocore/botocore-1.24.8.ebuild b/dev-python/botocore/botocore-1.24.8.ebuild
new file mode 100644
index 000000000000..35239170e3a4
--- /dev/null
+++ b/dev-python/botocore/botocore-1.24.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}