summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-30 09:14:51 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-19 08:27:28 +0300
commit36adeb0ac258004bfb98bca1fb1feb12efb9d550 (patch)
treee48be24624c72bb413eda768529f29960c0806ab
parentprofiles/package.mask: revert fast_gettext mask (diff)
downloadgentoo-36adeb0ac258004bfb98bca1fb1feb12efb9d550.tar.gz
gentoo-36adeb0ac258004bfb98bca1fb1feb12efb9d550.tar.bz2
gentoo-36adeb0ac258004bfb98bca1fb1feb12efb9d550.zip
app-dicts/ydpdict: Fix call to undeclared function textdomain
Upstream PR: https://github.com/wojtekka/ydpdict/pull/4 Closes: https://bugs.gentoo.org/894364 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32101 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-dicts/ydpdict/files/ydpdict-1.0.3-clang16-build-fix.patch12
-rw-r--r--app-dicts/ydpdict/ydpdict-1.0.3-r2.ebuild59
2 files changed, 71 insertions, 0 deletions
diff --git a/app-dicts/ydpdict/files/ydpdict-1.0.3-clang16-build-fix.patch b/app-dicts/ydpdict/files/ydpdict-1.0.3-clang16-build-fix.patch
new file mode 100644
index 000000000000..46a1956f80c7
--- /dev/null
+++ b/app-dicts/ydpdict/files/ydpdict-1.0.3-clang16-build-fix.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/894364
+Upstream PR: https://github.com/wojtekka/ydpdict/pull/4
+--- a/src/ydpdict.c
++++ b/src/ydpdict.c
+@@ -55,6 +55,7 @@
+
+ #ifdef HAVE_LOCALE_H
+ #include <locale.h>
++#include <libintl.h>
+ #endif
+
+ #ifdef HAVE_LIBAO
diff --git a/app-dicts/ydpdict/ydpdict-1.0.3-r2.ebuild b/app-dicts/ydpdict/ydpdict-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..e480c5092765
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-1.0.3-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Interface for the Collins Dictionary"
+HOMEPAGE="https://github.com/wojtekka/ydpdict"
+SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="ao"
+
+RDEPEND="
+ app-dicts/libydpdict
+ sys-libs/ncurses:=[unicode(+)]
+ ao? ( media-libs/libao )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+DOCS=(
+ README.md
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-tinfo.patch
+ "${FILESDIR}"/${PN}-1.0.3-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ao libao)
+}
+
+src_install() {
+ dodir "/etc"
+ default
+}
+
+pkg_postinst() {
+ echo
+ elog "Note that to use this program you'll need the original Collins Dictionary"
+ elog "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ elog "directory of the Windows version of the Collins dictionary. Once you obtain"
+ elog "the files, put them into /usr/share/ydpdict"
+ elog
+ elog "Some configuration options can be set in /etc/ydpdict.conf"
+ echo
+}