summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-09-02 23:24:31 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-09-02 23:25:16 +0900
commit36bf46805a98eb977542dd36f3328602d27a99bf (patch)
treee52eefea159e53aac3183ca34935285e7e8c983f
parentapp-i18n/libskk: update to EAPI 7 (diff)
downloadgentoo-36bf46805a98eb977542dd36f3328602d27a99bf.tar.gz
gentoo-36bf46805a98eb977542dd36f3328602d27a99bf.tar.bz2
gentoo-36bf46805a98eb977542dd36f3328602d27a99bf.zip
app-i18n/libskk: new upstream release
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/libskk/Manifest1
-rw-r--r--app-i18n/libskk/libskk-1.0.5.ebuild48
-rw-r--r--app-i18n/libskk/metadata.xml14
3 files changed, 56 insertions, 7 deletions
diff --git a/app-i18n/libskk/Manifest b/app-i18n/libskk/Manifest
index ab428f2bac66..df8b78b85415 100644
--- a/app-i18n/libskk/Manifest
+++ b/app-i18n/libskk/Manifest
@@ -1 +1,2 @@
DIST libskk-1.0.2.tar.gz 867572 BLAKE2B 32f599e83bf7ced796d2f37f6f4bf5e45f47c90e144784b7b3e082866cc619a26e3aca4f16051685baa4d8ac54b0462930193f978bc1e8220b378679269c5833 SHA512 f8fff94b216c18f66bf1004ee068f8d737177f1b70ac36d054d9a68ce02ba9b8d1b7b4127d9a330f64054b2fe06f352070c750a3562d4be36fecf20cb854e6c0
+DIST libskk-1.0.5.tar.xz 564488 BLAKE2B e7108bd2f44e5a0a0756cd25da4b07376b36604d6d2159b283e8a5f4ef76006210ff993d58b653cbce01ae4c9e003acf4acbd93ebc40711fec2600e514c49e9f SHA512 6db675edba89b83da0c29afb42644c39bcb0ccfc47f067a18e0eda817df4f58a86c86e8747080018c132d8734754a6fd8a30fe6578050eb93ff636edeed534ab
diff --git a/app-i18n/libskk/libskk-1.0.5.ebuild b/app-i18n/libskk/libskk-1.0.5.ebuild
new file mode 100644
index 000000000000..eab92a1f7f0c
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit vala virtualx
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://github.com/ueno/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ x11-libs/libxkbcommon
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND="memory"
+ virtx emake check
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-i18n/libskk/metadata.xml b/app-i18n/libskk/metadata.xml
index 47d519fd6058..8d9f83d4f2e9 100644
--- a/app-i18n/libskk/metadata.xml
+++ b/app-i18n/libskk/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ueno/libskk</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ueno/libskk</remote-id>
+ </upstream>
</pkgmetadata>