summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-20 21:42:07 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-20 21:43:28 -0500
commit36c08050933d9556f28968ab81ea19af723cec48 (patch)
tree4040c1fb64e345a4c84607377ad9b274beb3b79a
parentnet-proxy/trojan: bump PYTHON_COMPAT versions (diff)
downloadgentoo-36c08050933d9556f28968ab81ea19af723cec48.tar.gz
gentoo-36c08050933d9556f28968ab81ea19af723cec48.tar.bz2
gentoo-36c08050933d9556f28968ab81ea19af723cec48.zip
dev-php/pecl-http: Version bump for 4.0.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-4.0.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index eb018948dc41..833083f5d43d 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,3 +1,4 @@
DIST pecl_http-3.2.1.tgz 221244 BLAKE2B b6581829fb8a800e24ccedd4d0f3efbaf558850bdc356d27a6e1d1097a8e2cfc61963a1daccd1d0f269a7cef5b243d45cdfaff5138321fe20df615dde44d19e3 SHA512 e67d4b32ba6f524e3fcf65f5497b94275e1a4a14fce97c57afe366369f368b3acdbedf364ed73cf983fb2c5f57f498adaa1100e7c936f11cbc5de1caedad7b51
DIST pecl_http-3.2.3.tgz 220204 BLAKE2B 2a712dc8f69a8a80f6f8c306883df580fdff4a0d4cb0ac06cc004f8622b30b8e2f5d373276381fd3ad67657a80cc929be81745f200a98b6ed5e475de5639dfc5 SHA512 e955e3246db9a9172081dd9a077154139c585bfce546e91839052bbab4d0db9d0695122574a66891ceba5c0b7e8a8f0768274e1516521ccb95cd19504dc13666
+DIST pecl_http-4.0.0.tgz 218259 BLAKE2B c9f5973686fd4db95a24dd4c50f217b93becc6a439066a395b0b7fec6e977154e5ae8f2261414458aed8e4a9d1281f44da2ecc67a05127610579f5be91196a88 SHA512 268b569c23f10ed72fe3c84fc5e5bf526c3e5ac345ca0556a24fbd01ce95da468d4e9aac6300d058001534ab826836793bf901e9560b744f1e20d7059be2ec79
DIST pecl_http-4.0.0beta1.tgz 219277 BLAKE2B 184ea0a92fc514f24fd31aaec7824ba80293a52d168d11b3b3a9cea410df1bc9a6a819c45f301b357a3d19246e3c36b56f238c264579509eadf00fb42ae32d91 SHA512 d3e487d10e18e8af1a750d171e4432dd30562e1fb8d8ae7cbb33a379e3d385d27a6ce1896ed8f727802eae1045505254cb68840395098310e22f6dc640c5c616
diff --git a/dev-php/pecl-http/pecl-http-4.0.0.ebuild b/dev-php/pecl-http/pecl-http-4.0.0.ebuild
new file mode 100644
index 000000000000..a65db6f26344
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-4.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_INI_NAME="50-http"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php8-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="8"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+COMMON_DEPEND="app-arch/brotli:=
+ dev-libs/libevent
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-0(-)?]
+ net-dns/libidn2
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+"
+DEPEND="
+ php_targets_php8-0? ( ${COMMON_DEPEND} dev-lang/php:8.0[session,iconv] )"
+RDEPEND="${DEPEND}
+ php_targets_php7-3? ( dev-php/pecl-http:7[php_targets_php7-3(-)] )
+ php_targets_php7-4? ( dev-php/pecl-http:7[php_targets_php7-4(-)] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
+
+src_prepare() {
+ if use php_targets_php8-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php8-0 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
+
+src_test() {
+ # Cannot use eclass function due to required modules
+ # All tests SKIP otherwise
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Link in required modules for testing
+ ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
+ sed -i \
+ 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=raphf/' \
+ Makefile || die
+ SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
+ # Clean up testing links
+ rm modules/raphf.so || die
+ done
+}