summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-04 01:46:06 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-04 02:50:05 -0500
commit36d52f13055cc08e3227277f71602cad1d2ff376 (patch)
treef5a9d2a914678fcf3fd2ad6b56deb20580a10850
parentx11-terms/kitty: add 0.24.0 (diff)
downloadgentoo-36d52f13.tar.gz
gentoo-36d52f13.tar.bz2
gentoo-36d52f13.zip
x11-terms/kitty: sync live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index f47b4d2c18f8..dd602a094037 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,6 +38,7 @@ RDEPEND="
sys-libs/zlib:=
x11-libs/libxkbcommon[X?]
x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
~x11-terms/kitty-terminfo-${PV}
X? ( x11-libs/libX11 )
wayland? ( dev-libs/wayland )"
@@ -70,6 +71,17 @@ src_prepare() {
-i kitty_tests/check_build.py || die
use X || sed "/glfw_path('x11')/s/x11/wayland/" -i kitty_tests/glfw.py || die
+ # --shell-integration="enabled no-rc" is the intended way to set
+ # no-rc by default, but setup.py's replacer currently fails
+ # (no-rc prevents modifying users .bashrc without asking, and it's
+ # unnecessary given shell-integration package uses /etc/bash/bashrc.d)
+ sed -i "/shell_integration:/s/'enabled'/&,'no-rc'/" kitty/options/types.py || die
+
+ # test relies on 'who' command which typically works but have 1 VM
+ # where it didn't only under portage/sandbox, needs investigation but
+ # disable for now
+ rm kitty_tests/utmp.py || die
+
# skip docs for live version
[[ ${PV} != 9999 ]] || sed -i '/exists.*_build/,/docs(ddir)/d' setup.py || die
}
@@ -79,14 +91,13 @@ src_compile() {
export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local setup=(
- ${EPYTHON} setup.py
+ ${EPYTHON} setup.py linux-package
--disable-link-time-optimization
--ignore-compiler-warnings
--libdir-name=$(get_libdir)
--update-check-interval=0
--verbose
$(usev debug --debug)
- linux-package
)
echo "${setup[*]}"