summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-02-01 09:53:19 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-02-01 09:53:19 -0100
commit36dc4b135fa4e3acbc57783b0e560e10ca38c556 (patch)
tree0cf25843ce967506cb43d9545221ab9cbc113ed8
parentdev-util/cunit-2.1_p3-r0: alpha stable (diff)
downloadgentoo-36dc4b13.tar.gz
gentoo-36dc4b13.tar.bz2
gentoo-36dc4b13.zip
www-apps/dokuwiki: bump to hotfix 20180422b.
This hotfix fixes a PHP 7.3 compatibility issue and the ACL check. Release notes - https://www.dokuwiki.org/changes Thanks to boris for opening the bug requesting the bump. Closes: http://bugs.gentoo.org/676904 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--www-apps/dokuwiki/Manifest1
-rw-r--r--www-apps/dokuwiki/dokuwiki-20180422b.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index a8b08deb1d77..64daffe8e743 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,3 +1,4 @@
DIST dokuwiki-2016-06-26e.tgz 3464178 BLAKE2B cdeebee2f36cc899fcffe1d6df6f5beee8f7dd303db00a41fa4d187c27528971a8ea0fccffacb6331fe61f5854a9b2687ff55c2578d628164a39f817e4538a58 SHA512 b47c3a31b0bc731392703ed8d705717e7d1b75db0c44d822d8791c1e409d5285fe863a3dbd13bc60b73c01ca268f7a73a6a24c90edd211fd5c124d3a8be70039
DIST dokuwiki-2017-02-19e.tgz 3505643 BLAKE2B 99fedb175fa8e1330a4ad14ed8d593edfc1edb9aeb7d8b9100e940fb4c5bfac9dada2fe395e030cff18b8c809e36211fc9d0bdc22d5be3fae7f243343704218a SHA512 6fadb64f9d8394731f346708849d8828b33f4f775e23bca97896b2e06bbfc3b70a6fc17d63dcef8199fdb0aaf0b8291eb0eebcdff7b81524b2d454229eb20be4
DIST dokuwiki-2018-04-22a.tgz 3749191 BLAKE2B bb03b771e857a2db16ebd44d3f888af8e3c9dcd6fb5da2a549dc7c942ad87cb1e0aee6d3ed78edaa9df864804bf51cd18a17cf8a4123d12fac39405fe661bc04 SHA512 bf1dd7411abadedb395c9e12c7a9f5586fe078e59556b1ce66a5351c06f338406eca944d7589f40d8a9eb098da6ed0edc256f83ec8b19f6335415e2fe6c31284
+DIST dokuwiki-2018-04-22b.tgz 3745314 BLAKE2B 56c349c72038db83b5ae199ac1d6d00ef8566a00fdf2bc5a782e808e5205ae3ba5cfa47bdfc4f7fb0b2e493a22eed006517cfb46f7c0c57de748cfb800942f58 SHA512 6fc1fba8d93296d7cc795a4067e409339b3ce965ad38aefa42f1974d267ac05f199185e895a60d355ebe8371c68345fa51f2aea5871f955dbba1cdbdf8bedebf
diff --git a/www-apps/dokuwiki/dokuwiki-20180422b.ebuild b/www-apps/dokuwiki/dokuwiki-20180422b.ebuild
new file mode 100644
index 000000000000..1d99e100aff1
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20180422b.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="https://wiki.dokuwiki.org"
+SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-5.3[xml]
+ virtual/httpd-php:*
+ gd? ( ||
+ (
+ dev-lang/php[gd]
+ media-gfx/imagemagick
+ )
+ )
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # create initial changes file
+ touch data/changes.log
+
+ default
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Copy custom .htaccess that works with both apache 2.2 and 2.4
+ for dir in "conf" "data" "inc" "inc/lang"; do
+ insinto "${MY_HTDOCSDIR}/${dir}"
+ newins "${FILESDIR}/htaccess" ".htaccess"
+ done
+
+ # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
+ insinto "${MY_HTDOCSDIR}/"
+ newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}