summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:53 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:55 +0100
commit36e60f611685871c3cad9a54bfcca819d0b8013c (patch)
tree2157efc9c63be9f4219f30f03f2edbcfa11f4c13
parentdev-haskell/mono-traversable: add 1.0.15.3 (diff)
downloadgentoo-36e60f611685871c3cad9a54bfcca819d0b8013c.tar.gz
gentoo-36e60f611685871c3cad9a54bfcca819d0b8013c.tar.bz2
gentoo-36e60f611685871c3cad9a54bfcca819d0b8013c.zip
dev-haskell/mwc-random: add 0.15.0.2-r2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/mwc-random/Manifest2
-rw-r--r--dev-haskell/mwc-random/metadata.xml15
-rw-r--r--dev-haskell/mwc-random/mwc-random-0.15.0.2-r2.ebuild41
3 files changed, 44 insertions, 14 deletions
diff --git a/dev-haskell/mwc-random/Manifest b/dev-haskell/mwc-random/Manifest
index 9e7fc0f45b1e..dc55022b9c51 100644
--- a/dev-haskell/mwc-random/Manifest
+++ b/dev-haskell/mwc-random/Manifest
@@ -1 +1,3 @@
DIST mwc-random-0.14.0.0.tar.gz 19674 BLAKE2B 3410f8d237c8e4a0f079c13567082273fc79d287c8de2b9ea0c1f396271ba7571caf890d6065ae7f0e5aae41f66575d90df178b981db24c9792213facf1d9c3d SHA512 bb262d6f4a37d91e4c0667ec5140894ed36bf3ef4b90e487f4d689a6bc4eddd09dcdc3c8b75013124908ca1642e990c3e074fb728acc1b36f63b3db66528301d
+DIST mwc-random-0.15.0.2-rev1.cabal 3372 BLAKE2B 1e565e2028fe1cba958684ebfef4c3c248776402c8310e389c553084cae82c2451c19bd78567df9aa58fb926a8b10bf5e8fbec211c9bd0a33c3d0ac15b4f16e3 SHA512 7b3f2bb05148fc85ed4f85bbd96fbe6e836857a117c839cb2ceb51c4b17aa4ebc03b8989970cbf9b51aadfc6a9507a6af4dd864ec65b8b421456f46eee0974ed
+DIST mwc-random-0.15.0.2.tar.gz 26591 BLAKE2B 8320eaa28e5bc302104c8e9617e8e50728934d7143ea5a243570aed28cec5c98bb17d128460aed27dcbf5b3b71570a39f6247a3868cb18eb3f3c0325c20fed67 SHA512 7e30a4584bca7f5e5147388dc9c081ac417d3aff1e9bd431535eac695db0779b4d20c6b3bedbda06a4780d9d57ab1f7880743f7bad20e4f5d2b7d32ce7f373bd
diff --git a/dev-haskell/mwc-random/metadata.xml b/dev-haskell/mwc-random/metadata.xml
index 3bcd47064ae2..c6a1cbc7566e 100644
--- a/dev-haskell/mwc-random/metadata.xml
+++ b/dev-haskell/mwc-random/metadata.xml
@@ -5,21 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package contains code for generating high quality random
- numbers that follow either a uniform or normal distribution. The
- generated numbers are suitable for use in statistical applications.
-
- The uniform PRNG uses Marsaglia's MWC256 (also known as MWC8222)
- multiply-with-carry generator, which has a period of 2^8222 and
- fares well in tests of randomness. It is also extremely fast,
- between 2 and 3 times faster than the Mersenne Twister.
-
- Compared to the mersenne-random package, this package has a more
- convenient API, is faster, and supports more statistical
- distributions.
- </longdescription>
<upstream>
+ <remote-id type="hackage">mwc-random</remote-id>
<remote-id type="github">bos/mwc-random</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/mwc-random/mwc-random-0.15.0.2-r2.ebuild b/dev-haskell/mwc-random/mwc-random-0.15.0.2-r2.ebuild
new file mode 100644
index 000000000000..017026e79567
--- /dev/null
+++ b/dev-haskell/mwc-random/mwc-random-0.15.0.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, high quality pseudo random number generation"
+HOMEPAGE="https://github.com/bos/mwc-random"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'doctest >=0.15 && <0.20' 'doctest >=0.15'
+)
+
+RDEPEND="
+ >=dev-haskell/math-functions-0.2.1.0:=[profile?]
+ >=dev-haskell/primitive-0.6.2:=[profile?]
+ >=dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/doctest-0.15
+ >=dev-haskell/quickcheck-2.2
+ >=dev-haskell/tasty-1.3.1
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ >=dev-haskell/vector-0.12.1
+ )
+"