summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-01-03 18:02:09 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-01-03 18:03:59 +0100
commit36e7361b0799a35518fbab4d5ba778f9a4ebf951 (patch)
treecde50ccf041f293811f5d1e3b3676d080f6412b1
parentapp-containers/docker-cli: add 20.10.22 (diff)
downloadgentoo-36e7361b079.tar.gz
gentoo-36e7361b079.tar.bz2
gentoo-36e7361b079.zip
sci-visualization/pythonprop: add 0.30.1
Fix remote-id, drop notworking color scheme Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--sci-visualization/pythonprop/Manifest1
-rw-r--r--sci-visualization/pythonprop/files/pythonprop-drop-portland.patch87
-rw-r--r--sci-visualization/pythonprop/metadata.xml2
-rw-r--r--sci-visualization/pythonprop/pythonprop-0.30.1.ebuild55
4 files changed, 144 insertions, 1 deletions
diff --git a/sci-visualization/pythonprop/Manifest b/sci-visualization/pythonprop/Manifest
index 8f7709d8717c..71b0cf318210 100644
--- a/sci-visualization/pythonprop/Manifest
+++ b/sci-visualization/pythonprop/Manifest
@@ -1 +1,2 @@
+DIST pythonprop-0.30.1.tar.gz 1141620 BLAKE2B 54554d1a50976aa0516e70ef6cabf8c8c8fe41dc15980d0d06defca2dbf722baa4e98dddb974ea0d6da18e3d634661c980685b89411e8de4cf1cded452bb60a1 SHA512 582442e95732c78b580eceaf8b9d4922a23e5b3c5652738b110a40e1b94f91196755fad6e00370328130acc608121961d4e449199610137a757b086b53184b43
DIST pythonprop-0.30.tar.gz 1141872 BLAKE2B 0703358221825bbeffb47cd5ff97a8de4c22ed9922347b96e359c7fbeffd6bae681a81d4938c03f4199ce583821d6e1006ce2e12aa718f50b5de69f2c0476a38 SHA512 421cade49a241d0dd38afa92e2c1874e2e6a0837ac7aeb9f4a294a2cec23e80e446e88a4de202de445cde73b9d816f4d6e487536be8c02017f1754c116fba310
diff --git a/sci-visualization/pythonprop/files/pythonprop-drop-portland.patch b/sci-visualization/pythonprop/files/pythonprop-drop-portland.patch
new file mode 100644
index 000000000000..5a6736b4624b
--- /dev/null
+++ b/sci-visualization/pythonprop/files/pythonprop-drop-portland.patch
@@ -0,0 +1,87 @@
+# Drop 'portland' colormap creation. It is done more than once and actual
+# matplotlib do not like redefinitions.
+diff --git a/src/pythonprop/voaAreaPlot.py b/src/pythonprop/voaAreaPlot.py
+index a0bd789..a3bdd48 100644
+--- a/src/pythonprop/voaAreaPlot.py
++++ b/src/pythonprop/voaAreaPlot.py
+@@ -94,7 +94,7 @@ class VOAAreaPlot:
+ vg_files = [1],
+ data_type = 1,
+ time_zone = 0,
+- color_map = 'portland',
++ color_map = 'jet',
+ face_colour = "white",
+ filled_contours = False,
+ plot_contours = False,
+@@ -145,8 +145,6 @@ class VOAAreaPlot:
+ # print "-180 < Latitude < 180.0, -90 < Longitude < 90"
+ # sys.exit(1)
+
+- portland = ListedColormap(["#0C3383", "#0b599b","#0a7fb4","#57a18f","#bec255","#f2c438","#f2a638","#ef8235","#e4502a","#d91e1e"])
+- plt.register_cmap(name='portland', cmap=portland)
+ colMap = color_map
+
+ projection = ccrs.PlateCarree()
+@@ -498,8 +496,8 @@ def main(in_file, datadir=None):
+ dest = "color_map",
+ default = 'jet',
+ choices = [ 'autumn', 'bone', 'cool', 'copper', 'gray', \
+- 'hot', 'hsv', 'jet', 'pink', 'spring','summer', 'winter', 'portland' ],
+- help=_("COLOURMAP - may be one of 'autumn', 'bone', 'cool', 'copper', 'gray', 'hot', 'hsv', 'jet', 'pink', 'spring', 'summer', 'winter' or 'portland'. Default = 'jet'"))
++ 'hot', 'hsv', 'jet', 'pink', 'spring','summer', 'winter' ],
++ help=_("COLOURMAP - may be one of 'autumn', 'bone', 'cool', 'copper', 'gray', 'hot', 'hsv', 'jet', 'pink', 'spring', 'summer' or 'winter'. Default = 'jet'"))
+ """
+ parser.add_argument("-n", "--interest",
+ dest = "poi_file",
+diff --git a/src/pythonprop/voaAreaPlotgui.py b/src/pythonprop/voaAreaPlotgui.py
+index c001397..9f75acc 100644
+--- a/src/pythonprop/voaAreaPlotgui.py
++++ b/src/pythonprop/voaAreaPlotgui.py
+@@ -84,8 +84,7 @@ class VOAAreaPlotGUI:
+ 'pink': _('pink'),
+ 'spring': _('spring'),
+ 'summer': _('summer'),
+- 'winter': _('winter'),
+- 'portland': _('portland')}
++ 'winter': _('winter')}
+
+ def __init__(self,
+ data_source_filename,
+diff --git a/src/pythonprop/voaP2PPlot.py b/src/pythonprop/voaP2PPlot.py
+index faf87e6..61fe9b9 100644
+--- a/src/pythonprop/voaP2PPlot.py
++++ b/src/pythonprop/voaP2PPlot.py
+@@ -136,8 +136,6 @@ class VOAP2PPlot:
+
+ self.image_defs = self.IMG_TYPE_DICT[self.data_type]
+ self.user_bands = user_bands
+- portland = ListedColormap(["#0C3383", "#0b599b","#0a7fb4","#57a18f","#bec255","#f2c438","#f2a638","#ef8235","#e4502a","#d91e1e"])
+- matplotlib.cm.register_cmap(name='portland', cmap=portland)
+
+ if plot_groups[0]=='a':
+ num_grp = self.df.get_number_of_groups()
+@@ -375,8 +373,8 @@ def main(data_file, datadir=None):
+ dest="color_map",
+ default='jet',
+ choices = [ 'autumn', 'bone', 'cool', 'copper', 'gray', \
+- 'hot', 'hsv', 'jet', 'pink', 'spring','summer', 'winter', 'portland' ],
+- help=_("COLOURMAP - may be one of 'autumn', 'bone', 'cool', 'copper', 'gray', 'hot', 'hsv', 'jet', 'pink', 'spring', 'summer', 'winter' or 'portland'. Default = 'jet'"))
++ 'hot', 'hsv', 'jet', 'pink', 'spring','summer', 'winter' ],
++ help=_("COLOURMAP - may be one of 'autumn', 'bone', 'cool', 'copper', 'gray', 'hot', 'hsv', 'jet', 'pink', 'spring', 'summer' or 'winter'. Default = 'jet'"))
+
+ parser.add_argument("-o", "--outfile",
+ dest="save_file",
+diff --git a/src/pythonprop/voaP2PPlotgui.py b/src/pythonprop/voaP2PPlotgui.py
+index e1c120b..0aca557 100644
+--- a/src/pythonprop/voaP2PPlotgui.py
++++ b/src/pythonprop/voaP2PPlotgui.py
+@@ -83,8 +83,7 @@ class VOAP2PPlotGUI:
+ 'pink': _('pink'),
+ 'spring': _('spring'),
+ 'summer': _('summer'),
+- 'winter': _('winter'),
+- 'portland': _('portland')}
++ 'winter': _('winter')}
+
+
+ def __init__(self, data_source_filename, parent = None, datadir=""):
diff --git a/sci-visualization/pythonprop/metadata.xml b/sci-visualization/pythonprop/metadata.xml
index 27c9a899306a..fbf434b3fa36 100644
--- a/sci-visualization/pythonprop/metadata.xml
+++ b/sci-visualization/pythonprop/metadata.xml
@@ -10,6 +10,6 @@
<name>Gentoo Electronics Project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">pythonprop</remote-id>
+ <remote-id type="github">jawatson/pythonprop</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sci-visualization/pythonprop/pythonprop-0.30.1.ebuild b/sci-visualization/pythonprop/pythonprop-0.30.1.ebuild
new file mode 100644
index 000000000000..55899af5d1bf
--- /dev/null
+++ b/sci-visualization/pythonprop/pythonprop-0.30.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Scripts to prepare and plot VOACAP propagation predictions"
+HOMEPAGE="https://www.qsl.net/h/hz1jw/pythonprop"
+SRC_URI="https://github.com/jawatson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ ')
+ dev-python/cairocffi
+ sci-libs/cartopy[${PYTHON_SINGLE_USEDEP}]
+ sci-electronics/voacapl
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ app-text/rarian
+"
+
+PATCHES=( "${FILESDIR}/${PN}-drop-portland.patch" )
+
+src_prepare() {
+ eapply_user
+
+ eapply ${PATCHES[@]}
+
+ # drop building *.pdf files
+ sed -i -e "s#docs/user/help##g" Makefile.am || die
+ # do not call update_destop_database here
+ sed -ie "s/UPDATE_DESKTOP = /UPDATE_DESKTOP = # /g" data/Makefile.am || die
+ # fix Desktop Entry
+ sed -ie "s/HamRadio/HamRadio;/g" data/voacapgui.desktop.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ python_optimize
+}