summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-07-04 17:34:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-07-04 17:34:56 +0200
commit37115c974ee894253dd3daed491eee2f13129c29 (patch)
tree5fa2ce71d71e2ceaf5c5e8345514e057e0b930b3
parentapp-emulation/runc: Remove old and unmaintained live (diff)
downloadgentoo-37115c974ee894253dd3daed491eee2f13129c29.tar.gz
gentoo-37115c974ee894253dd3daed491eee2f13129c29.tar.bz2
gentoo-37115c974ee894253dd3daed491eee2f13129c29.zip
app-emulation/containerd: Remove old and unmaintained live
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--app-emulation/containerd/Manifest3
-rw-r--r--app-emulation/containerd/containerd-1.1.2.ebuild55
-rw-r--r--app-emulation/containerd/containerd-1.1.4.ebuild55
-rw-r--r--app-emulation/containerd/containerd-1.2.5.ebuild56
-rw-r--r--app-emulation/containerd/containerd-9999.ebuild40
5 files changed, 0 insertions, 209 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 11961b23491d..989fa6368005 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,4 +1 @@
-DIST containerd-1.1.2.tar.gz 5124208 BLAKE2B d989519d6bef4e12d1fa04aa00bfee223e94676a90525304d4357f4caf46326b4d2b897b885e9e137fe01ce66b93bc92fb7da7bd2b5dd5019edda5bb0bbc6d0a SHA512 fe4121a43e72a354cd87577b5227f2c2e0d54674244001e6fdb695da78873b3fd3f46b6bda6bbd0c8793b33f50e0d725cb356bb75b789a273c862bbe7d4f719c
-DIST containerd-1.1.4.tar.gz 5328134 BLAKE2B cb69f9bd80bc279ae2bd85c75152dacdbdf13df9aa2efae2453c11bf6ea9b990a4e8ec3cb07778ff1b07ef2fbc05d19bb5714616fa5618f590dc8c5b5c2b2bd0 SHA512 c51b3168b8d8121b1479f75f5ba21280848bb1cbed2d2c4a7e315ec24d1805fc9c512a1fc53e8e8fc32e150c7f2becb8daca0ecab4eaf760b3274c11fbcd6ea8
-DIST containerd-1.2.5.tar.gz 4871876 BLAKE2B f8652d00b4338d0f4a1d77d452a46c316cc38b57f2df64fcfcef463f10d030f363b54f1a12c4cb32d9010872c688a75ebc1d481439dc3eb84aab193fc80c9bc0 SHA512 b249d5bfc0c1f884ecc1ad4544f9440405450c31f11e80ac094bfddb7a6660e950116114e563d7655e07f888f2ff62f4476f2b178f4e0e2acbbb9fb84a243b25
DIST containerd-1.2.6.tar.gz 4874159 BLAKE2B 202e19cffbe2b5335558dc1db28ea28a05dcc9e9b3aad864e090d86f7590df9e67ae685c9fc6ab2b8abdd1762d001fa9b298b1d311c080449bc86087b6af8c36 SHA512 287b064cb3e57369e34f6debb434526d6bd4857e337e489c56e4ca484c66e161bbda911b4fc29cb49808a756f6ec7af5629e46d693644500e3bf2d9e45e87e73
diff --git a/app-emulation/containerd/containerd-1.1.2.ebuild b/app-emulation/containerd/containerd-1.1.2.ebuild
deleted file mode 100644
index b37434d56613..000000000000
--- a/app-emulation/containerd/containerd-1.1.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/containerd/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_rc/-rc.}"
- EGIT_COMMIT="v${MY_PV}"
- CONTAINERD_COMMIT="468a545b9edcd5932818eb9de8e72413e616e86e"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor +btrfs +cri hardened +seccomp"
-
-DEPEND="btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )"
-RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
- >=app-emulation/runc-1.0.0_rc4 )
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RESTRICT="test"
-
-src_prepare() {
- default
- if [[ ${PV} != *9999* ]]; then
- sed -i -e "s/git describe --match.*$/echo ${PV})/"\
- -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
- -e "s/-s -w//" \
- Makefile || die
- fi
-}
-
-src_compile() {
- local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
-}
-
-src_install() {
- dobin bin/containerd{-shim,-stress,} bin/ctr
-}
diff --git a/app-emulation/containerd/containerd-1.1.4.ebuild b/app-emulation/containerd/containerd-1.1.4.ebuild
deleted file mode 100644
index 0d07ff805fcc..000000000000
--- a/app-emulation/containerd/containerd-1.1.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/containerd/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_rc/-rc.}"
- EGIT_COMMIT="v${MY_PV}"
- CONTAINERD_COMMIT="9f2e07b1fc1342d1c48fe4d7bbb94cb6d1bf278b"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor +btrfs +cri hardened +seccomp"
-
-DEPEND="btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )"
-RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
- >=app-emulation/runc-1.0.0_rc4 )
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RESTRICT="test"
-
-src_prepare() {
- default
- if [[ ${PV} != *9999* ]]; then
- sed -i -e "s/git describe --match.*$/echo ${PV})/"\
- -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
- -e "s/-s -w//" \
- Makefile || die
- fi
-}
-
-src_compile() {
- local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
-}
-
-src_install() {
- dobin bin/containerd{-shim,-stress,} bin/ctr
-}
diff --git a/app-emulation/containerd/containerd-1.2.5.ebuild b/app-emulation/containerd/containerd-1.2.5.ebuild
deleted file mode 100644
index 4df44a02efb8..000000000000
--- a/app-emulation/containerd/containerd-1.2.5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/containerd/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_rc/-rc.}"
- EGIT_COMMIT="v${MY_PV}"
- CONTAINERD_COMMIT="bb71b10fd8f58240ca47fbb579b9d1028eea7c84"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor +btrfs +cri hardened +seccomp"
-
-DEPEND="btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )"
-RDEPEND=">=app-emulation/runc-1.0.0_rc5
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RESTRICT="test"
-
-src_prepare() {
- default
- if [[ ${PV} != *9999* ]]; then
- sed -i -e "s/git describe --match.*$/echo ${PV})/"\
- -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
- -e "s/-s -w//" \
- Makefile || die
- fi
-}
-
-src_compile() {
- local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
-}
-
-src_install() {
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- keepdir /var/lib/containerd
- dobin bin/*
-}
diff --git a/app-emulation/containerd/containerd-9999.ebuild b/app-emulation/containerd/containerd-9999.ebuild
deleted file mode 100644
index 345b3fa9b966..000000000000
--- a/app-emulation/containerd/containerd-9999.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/containerd/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_beta/-beta.}"
- EGIT_COMMIT="v${MY_PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="hardened +seccomp"
-
-DEPEND=""
-RDEPEND=">=app-emulation/runc-1.0.0_rc4
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-src_compile() {
- local options=( $(usex seccomp "seccomp" "") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin bin/containerd{-shim,-stress,} bin/ctr
-}