summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-09-14 20:33:36 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-09-14 20:33:53 +0200
commit371d948ee3eed8bbf148724405490564c0c73a1a (patch)
tree8421420a53978195826aed6ee36ec9c28b61f98c
parentdev-util/bpftool: Remove old 5.12 (diff)
downloadgentoo-371d948e.tar.gz
gentoo-371d948e.tar.bz2
gentoo-371d948e.zip
media-gfx/chafa: Version bump to 1.8.0
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.8.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index 3b822560cee1..8b8491c090b8 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
DIST chafa-1.6.1.tar.xz 418720 BLAKE2B 5f6c42311d81bf508f5ec890d72508fd2255e226102b8a7c5c71a9bc1293cd75b08c6b640ca4e6fe9ae34ad47e4e408e25a1aeed7057a5bd823550bea4526f4a SHA512 96cf772638e1a6874d94636a69d6c76d1040d956a16be851ea818292f5b2252867acd0891fede3e030de591b5567d820cf062c5a103a0943a0ea2f2ba34eea77
+DIST chafa-1.8.0.tar.xz 435712 BLAKE2B 15a6e64fff13ac32b2f828a68fb12c96856e175eae83c0396b07cbb2ce71d8c1c8eee67db00880372026fe91eaefac2b34376dee597108ffc07c706cf8c98682 SHA512 15ff08a0df82ae8517ac7744b81a39e1ae1eff8c9848128341cc25da94864e89b7101aabcff2d532bf11ea293bfc4c9e48b01f85388dafadbce2d2b2c8b7439d
diff --git a/media-gfx/chafa/chafa-1.8.0.ebuild b/media-gfx/chafa/chafa-1.8.0.ebuild
new file mode 100644
index 000000000000..0949da594e0d
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}