summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:01:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:38:19 +0300
commit372958fead083b7188e60309b81672faa39896ae (patch)
tree578b737c5295f395de460ccc68b50d2d265d3550
parentdev-python/pyproj: add 3.4.0 (diff)
downloadgentoo-372958fe.tar.gz
gentoo-372958fe.tar.bz2
gentoo-372958fe.zip
dev-python/oauthlib: add 3.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/oauthlib/Manifest1
-rw-r--r--dev-python/oauthlib/oauthlib-3.2.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/oauthlib/Manifest b/dev-python/oauthlib/Manifest
index 2c92c9dd8b19..62cb18e236c0 100644
--- a/dev-python/oauthlib/Manifest
+++ b/dev-python/oauthlib/Manifest
@@ -1 +1,2 @@
DIST oauthlib-3.2.0.tar.gz 163829 BLAKE2B cf14aeea253bc25f696bb638f364ff74d1a695a0f72dc8a77e2a5433e20672a5cf4a7b25f222940a08a5a26b503e671258ef26ee96e121fa016fbec3d6c5c874 SHA512 abb052cbaccb00a61e9a6c0028102927310d2d864d853cd0826c9a8eae8a9e921da33b79be554a3c6f6067cbcf43b25140f5224c8ab1e7f0a4eb6ab227d418a3
+DIST oauthlib-3.2.1.tar.gz 176109 BLAKE2B 69da6e8ae0efac3928b0e8ee0be1eb57f0871b4a9361f7347a0abfabf183f82bf8431d0247168531dd5fb12c6df2e8a55e5f95f3df1da2d3c8931a6b1751fe4c SHA512 87fa320f3a660337a2d4da03c4b5f2345f7e907c1acf8fff93cf13095ceb699e282dc458fb03350b0da371c7b2af875925e808bccab6d8549f7ce2847e69aba3
diff --git a/dev-python/oauthlib/oauthlib-3.2.1.ebuild b/dev-python/oauthlib/oauthlib-3.2.1.ebuild
new file mode 100644
index 000000000000..c9f783b21010
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-3.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/oauthlib/oauthlib https://pypi.org/project/oauthlib/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest