summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-30 10:46:06 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-30 11:25:28 -0500
commit3750544f26a7427b92b102c1cd2253b2c66cee81 (patch)
treec3e61774f0c5d338d22fb868fc860f18ce86a183
parentdev-libs/librevenge: add 0.0.5 (diff)
downloadgentoo-3750544f.tar.gz
gentoo-3750544f.tar.bz2
gentoo-3750544f.zip
media-video/mpv: skip img_format and repack_sws test
This seems to be mostly inconsistencies than actual issues. Thanks to ernsteiswuerfel for verifying runtime is fine on real hardware. Tried with ppc64 qemu and the other tests don't fail. Closes: https://bugs.gentoo.org/888639 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-video/mpv/mpv-0.35.0-r1.ebuild17
-rw-r--r--media-video/mpv/mpv-9999.ebuild17
2 files changed, 32 insertions, 2 deletions
diff --git a/media-video/mpv/mpv-0.35.0-r1.ebuild b/media-video/mpv/mpv-0.35.0-r1.ebuild
index 2fb3855a1bfd..d979c38b602c 100644
--- a/media-video/mpv/mpv-0.35.0-r1.ebuild
+++ b/media-video/mpv/mpv-0.35.0-r1.ebuild
@@ -250,7 +250,22 @@ src_configure() {
src_test() {
# https://github.com/mpv-player/mpv/blob/master/DOCS/man/options.rst#debugging
- edo "${BUILD_DIR}"/mpv --no-config -v --unittest=all-simple
+ local tests=($("${BUILD_DIR}"/mpv --no-config --unittest=help | tail -n +2; assert))
+ (( ${#tests[@]} )) || die "failed to gather any tests"
+
+ local skip=(
+ all-simple
+
+ # fails on non-issue minor inconsistencies (bug #888639)
+ img_format
+ repack_sws
+ )
+
+ local test
+ for test in "${tests[@]}"; do
+ [[ ${test} == @($(IFS='|'; echo "${skip[*]}")) ]] ||
+ edo "${BUILD_DIR}"/mpv -v --no-config --unittest="${test}"
+ done
}
src_install() {
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index a7b00cd2fc59..0f9e5d85df07 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -250,7 +250,22 @@ src_configure() {
src_test() {
# https://github.com/mpv-player/mpv/blob/master/DOCS/man/options.rst#debugging
- edo "${BUILD_DIR}"/mpv --no-config -v --unittest=all-simple
+ local tests=($("${BUILD_DIR}"/mpv --no-config --unittest=help | tail -n +2; assert))
+ (( ${#tests[@]} )) || die "failed to gather any tests"
+
+ local skip=(
+ all-simple
+
+ # fails on non-issue minor inconsistencies (bug #888639)
+ img_format
+ repack_sws
+ )
+
+ local test
+ for test in "${tests[@]}"; do
+ [[ ${test} == @($(IFS='|'; echo "${skip[*]}")) ]] ||
+ edo "${BUILD_DIR}"/mpv -v --no-config --unittest="${test}"
+ done
}
src_install() {