summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-30 20:30:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-30 20:45:01 +0100
commit3779ebef95209d30fde3b3e40ea730ac36db971a (patch)
treec356ab40d70f75073ebbcd96af97d2d466d6b464
parentnet-misc/smb4k: add 3.2.5 (diff)
downloadgentoo-3779ebef95209d30fde3b3e40ea730ac36db971a.tar.gz
gentoo-3779ebef95209d30fde3b3e40ea730ac36db971a.tar.bz2
gentoo-3779ebef95209d30fde3b3e40ea730ac36db971a.zip
app-text/liblangtag: add 0.6.6
Closes: https://bugs.gentoo.org/918852 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/liblangtag/Manifest1
-rw-r--r--app-text/liblangtag/liblangtag-0.6.6.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-text/liblangtag/Manifest b/app-text/liblangtag/Manifest
index 3ea02dd0fb2c..e24d91eb4dbb 100644
--- a/app-text/liblangtag/Manifest
+++ b/app-text/liblangtag/Manifest
@@ -1,2 +1,3 @@
DIST liblangtag-0.6.4.tar.bz2 764946 BLAKE2B 1d94f341359f880acb8a0a0526da625cb39d85b33665b861c0fbd94064228a3d5328f3a3b7d62bffd29c6ff8161fa499b6565010ba3065c90f87b5902969e81f SHA512 6c6dd3e6b0fc8d6f10cafd74112cbaf2a2342a88a908ad2f7ae759b3f5fb0cf6d788504c1de072e9ef019f2f5a284daeb2d2393036b6b402c5bc87f32b55f271
DIST liblangtag-0.6.5.tar.bz2 756562 BLAKE2B 79208849ebf1c17b9214d783fc53b9224f9034d1c0af1fab519d4a2b0a452ca713ec4e89830b6023adfbb08c5f557e0baf5438d4ee36c1af004ae351c1d59218 SHA512 20bd9babdf146338a34d6f032fb3ac2851171a0cc49332e211fc75f381cc97d21f24df9ff2bf4c322993f0b9b87c2f1b96d9289f4f7d0786281e662f3e682e55
+DIST liblangtag-0.6.6.tar.bz2 757043 BLAKE2B 0ebed81d7776e02a163f9a20bab73c41334ed2c1f620a1a56f56bc883f5b6741ab5ca3d77ed564fd05c46342e2a73a2df73cef29a7d53bc478b4a1a682148497 SHA512 9cb62b91994dba8d5781d764f4149ac3a7b8dd89514bbe627a6776d5674698a1d7ca520b880f35a2406b220fdad19f46de0d3a55bcc5eaad0f02a11061d44496
diff --git a/app-text/liblangtag/liblangtag-0.6.6.ebuild b/app-text/liblangtag/liblangtag-0.6.6.ebuild
new file mode 100644
index 000000000000..80aec8d4c9ca
--- /dev/null
+++ b/app-text/liblangtag/liblangtag-0.6.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Interface library to access tags for identifying languages"
+HOMEPAGE="https://bitbucket.org/tagoh/liblangtag/wiki/Home"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-3 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="debug doc introspection test"
+
+# Upstream expect liblangtag to be installed when one runs tests...
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+"
+BDEPEND="
+ sys-devel/gettext
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection-common )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ if [[ -d docs/html ]]; then
+ rm -r docs/html || die "Failed to remove existing gtk-doc"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ $(use_enable introspection)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}