summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 17:50:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 17:50:28 +0100
commit3782061d2e427058a68ff380a1bd322f9fea576b (patch)
treeef518a540565fcb5ec2bd11466ab3a1acb4482b6
parentdev-libs/libgcrypt: Stabilize 1.10.1-r2 x86, #878749 (diff)
downloadgentoo-3782061d.tar.gz
gentoo-3782061d.tar.bz2
gentoo-3782061d.zip
xfce-base/libxfce4util: Bump to 4.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.17.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index d8eda3bd203e..50e6dac3f9bb 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.16.0.tar.bz2 508328 BLAKE2B 99578b898389bd90841a7f903f5473b2ff357cf81256efe1019425b48da32401ce238deffefd299987477f4cdfb77e86e415b55049863c30bf16e0e641e08c72 SHA512 dce6992c3da73367461d7464794a9b2a5503666113682e07a86e18b1c5383de2b087809448d5729097571f4fda6b4af5f4f4600848514ab2ab4b3f367ca26f5c
DIST libxfce4util-4.17.2.tar.bz2 518831 BLAKE2B 4f1241271edab56063c8e5f3ad6b662a19b08ea06c73eb76e124d9fc8cd9a2b26578517fc6e4b0d5e8c3351877c7b5e077818b916297ac24e273c745cb624eec SHA512 3f079570916c3876373155a3ea15b6326ddadd815efdf7d7abd2ccd9768a96b3191f4e050bb51f2e28bc6b121b7ef9823e7a4caf608398220f527a4df7e29c6f
+DIST libxfce4util-4.17.3.tar.bz2 511545 BLAKE2B 9b198099277b073c67265bca8f63fe42526de6ee7f4d43b0b1c767edcb6f47c29751b78dfe4f38b569cdb3448e8e2eaf3da7556b2c4f09ba6a9a54a0f0946b40 SHA512 b943390b8ffd0b765e945cd1045d97c66203ae77b5c8e0ecd253f527a75fbf07beaea138877e9d4b3e09ad2f89747ebfe3b6d40cb9472e6bdec475309c3ec0cc
diff --git a/xfce-base/libxfce4util/libxfce4util-4.17.3.ebuild b/xfce-base/libxfce4util/libxfce4util-4.17.3.ebuild
new file mode 100644
index 000000000000..8d73500053d8
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.17.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4util/start
+ https://gitlab.xfce.org/xfce/libxfce4util/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}