summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-06-29 12:12:24 +0700
committerJoonas Niilola <juippis@gentoo.org>2022-07-05 12:06:39 +0300
commit379f11d5a39579e75606d13eec3543f1f5e6c061 (patch)
treeae27736f892bf4964e13c0f8614fb8c98ea986d8
parentnet-im/ejabberd: amd64 stable wrt bug #856508 (diff)
downloadgentoo-379f11d5a39579e75606d13eec3543f1f5e6c061.tar.gz
gentoo-379f11d5a39579e75606d13eec3543f1f5e6c061.tar.bz2
gentoo-379f11d5a39579e75606d13eec3543f1f5e6c061.zip
app-text/jo: bump to 1.6 and 9999
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/26132 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/jo/Manifest1
-rw-r--r--app-text/jo/jo-1.6.ebuild33
-rw-r--r--app-text/jo/jo-9999.ebuild33
-rw-r--r--app-text/jo/metadata.xml15
4 files changed, 78 insertions, 4 deletions
diff --git a/app-text/jo/Manifest b/app-text/jo/Manifest
index 51d13aea3032..d415981d9743 100644
--- a/app-text/jo/Manifest
+++ b/app-text/jo/Manifest
@@ -1 +1,2 @@
DIST jo-1.4.tar.gz 144596 BLAKE2B 0e0a0290d276b18fbfea0c770e134f29ea3f1eea9c7e5ccdd6c7d853dc0a8c70279fa464731f5b231d6d9d48816be4e5a6d93c7abc0e03408a86f0e1691d67a0 SHA512 c283b25e76fa06842c4f7d8ae8d94b207981d92a1bd4a064631e0646bdeedc06c1a00dddac405a455b27bda5eb34aaa7dc6d886ccf750741fd4d7312f692d169
+DIST jo-1.6.tar.gz 151941 BLAKE2B 13d7d68c33d7f89ebb4a5cdb448082bd4d245060ebf8c85149c39f2a184f03f1ac1c380833a742894c37c0815e3627569cfe29f202f9aa3dcec7fa089f99b918 SHA512 a2cb1327c8255e0f8d1b6e6056bbce081d7703192bdb974e908549b863d7db645531dbeff87629a6ed53626295ab7ca8a72816d104f9188846ef175c8a9acb07
diff --git a/app-text/jo/jo-1.6.ebuild b/app-text/jo/jo-1.6.ebuild
new file mode 100644
index 000000000000..996d861cee82
--- /dev/null
+++ b/app-text/jo/jo-1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools bash-completion-r1
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+else
+ SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${D}"$(get_bashcompdir)/jo{.bash,} || die
+}
diff --git a/app-text/jo/jo-9999.ebuild b/app-text/jo/jo-9999.ebuild
new file mode 100644
index 000000000000..996d861cee82
--- /dev/null
+++ b/app-text/jo/jo-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools bash-completion-r1
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+else
+ SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${D}"$(get_bashcompdir)/jo{.bash,} || die
+}
diff --git a/app-text/jo/metadata.xml b/app-text/jo/metadata.xml
index 6aaa98d22ea0..602b4237d04e 100644
--- a/app-text/jo/metadata.xml
+++ b/app-text/jo/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">jpmens/jo</remote-id>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <name>Thamognya Kodi</name>
+ <email>contact@thamognya.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jpmens/jo</remote-id>
+ </upstream>
</pkgmetadata>