summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-19 13:05:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-19 13:07:27 +0100
commit37a8e76548e74a613935f5452c3a1a5eefc35e4b (patch)
tree06de89c2295760aada34ece33b730c8a2e99c0db
parentdev-ml/iTeML: bump to 2.5 (diff)
downloadgentoo-37a8e76548e74a613935f5452c3a1a5eefc35e4b.tar.gz
gentoo-37a8e76548e74a613935f5452c3a1a5eefc35e4b.tar.bz2
gentoo-37a8e76548e74a613935f5452c3a1a5eefc35e4b.zip
sci-mathematics/coq: bump to 8.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.6.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 34d9f5eca974..9cf421cebdcc 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -2,3 +2,4 @@ DIST coq-8.5.tar.gz 5346653 SHA256 89a92fb8b91e7cb0797d41c87cd13e4b63bee76c32a6d
DIST coq-8.5pl1.tar.gz 5364928 SHA256 97047fc5e628f22e308efd3e86f625ae0504507decb96f2541e8e67eeaac20e8 SHA512 d907398e293cfc708c9314b3bbd57abf0806883cc1891d2b428f24e338953147586c0754e880fe679dfa893278335376287f6667db6c83dc7cb44a9e8afaddd1 WHIRLPOOL 7c65fd6a6804691492968d8b38cbbd34ac3fb9773cdea368679c206f735400d378e6d3786ce1955b22ac5ec4811beefaf83a6b656fb46a855e75c00c00608f21
DIST coq-8.5pl2.tar.gz 5321862 SHA256 83239d1251bf6c54a9ca5045d738e469019b93ca601756bf982aab0654e4de73 SHA512 0a0c7678eb92bbf3328a9667c66ff3bf59bc7fa6dea790ac1e1b2f4a7ab3121fb1ff01d18c2fc1bed53455286d0c507fe73cfccc1680ed3a219e773ab299f3af WHIRLPOOL 89b632538fd10afd2257aaf2b0acb26f4d2d49a7492583c039f88df6876ac27fc804b5854ee353d98cda64c2da3bf5571d7b9fde1cb9ceb50a90769633de18c7
DIST coq-8.5pl3.tar.gz 5335502 SHA256 305b92e05d406d4d0c64f43d4fadb6b89419120a1d4ae4115ed1c5eb8812d33b SHA512 3093c71769135479526a6ffea05929fe640046fd376e4369a0f8308915d0eeac3330a62d3309bd062a9dd46739bd2497d43e4885ed188a8e4d9b7ca016e89402 WHIRLPOOL 95798242e7b808776f97c3c7896c100f89bacba4978c7179b6275a02c1db9ab8f3c01a823ba5d9d276ca5defabea24db296e70dc2ac9525ec64aa88dead94281
+DIST coq-8.6.tar.gz 5538848 SHA256 6e3c3cf5c8e2b0b760dc52738e2e849f3a8c630869659ecc0cf41413fcee81df SHA512 9f5f4913fda8cf83683fec9398b42d4567207c3d4b52b4638d5e09a24ed25a43905fb57a9fac1bb9f9d681bd47f3560e1da74e79348b3a3fd93e2e8c686cebae WHIRLPOOL 714226c0f9138ea7dc9828db6dbc59e9b6e0c18ae305fc1a67c5c1c7a950ec1deabd37f462e20d1d1ddbd148a8bc3845a72f88f5ef6cbd4f93abfd02539dbcbc
diff --git a/sci-mathematics/coq/coq-8.6.ebuild b/sci-mathematics/coq/coq-8.6.ebuild
new file mode 100644
index 000000000000..3e10d3367040
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc camlp5"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.11.2:=[ocamlopt?]
+ camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
+ !camlp5? ( dev-ml/camlp4:= )
+ gtk? ( >=dev-ml/lablgtk-2.10.1:=[sourceview,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathextra
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -emacslib /usr/share/emacs/site-lisp
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ -lablgtkdir ${ocaml_lib}/lablgtk2
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ if use camlp5; then
+ myconf+=( -usecamlp5 -camlp5dir ${ocaml_lib}/camlp5 )
+ else
+ myconf+=( -usecamlp4 )
+ fi
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README.md CREDITS CHANGES
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}