summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-04-25 17:32:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-25 17:35:58 +0200
commit37b44db02fb579121b90a9f6696643c0ff42579b (patch)
treea14df7b4fab2a51a04bf4dfd712ce86092f1169b
parentdev-php/pecl-mongodb: bump to v1.9.1 (diff)
downloadgentoo-37b44db0.tar.gz
gentoo-37b44db0.tar.bz2
gentoo-37b44db0.zip
dev-php/adodb: bump to v5.21.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-php/adodb/Manifest1
-rw-r--r--dev-php/adodb/adodb-5.21.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/adodb/Manifest b/dev-php/adodb/Manifest
index 0c9bcc03f072..c55bc9321fb1 100644
--- a/dev-php/adodb/Manifest
+++ b/dev-php/adodb/Manifest
@@ -1,3 +1,4 @@
DIST adodb-5.20.14.tar.gz 465896 BLAKE2B acd8494141584b0c02c2e30aa59b3916ae811b8095ca724d22f44ed2cb1456b8e8afc7ff9af41e7476f4a93809e762c44a175fd3775b69654107813342b3a47a SHA512 fa9b764742f3edf15e79da7a34ca52b19f51454fa20bc963cce963cdd40f7e78671e993cd672a21e9917aa2440c63601fbf768b5259dccb64b458a5be6f4b0eb
DIST adodb-5.20.18.tar.gz 467003 BLAKE2B ea0b007359a4fdada0fface3d5af82c335f2e7efeacdbb66be37914d76bff2783b58b2318531c527d13c3c358800803385c660c8f9372cf4a49269ed7e0c7d51 SHA512 09b04987e20a674a202be3889523b3bada578ea01f07830fed15afafb046687004b4e305a6abf2af795a7b0e3563f6e8afec5b0189f21e5c74b5e84bfbee1cd9
DIST adodb-5.20.20.tar.gz 469337 BLAKE2B cffe367e498978b095e28bab565c8af7e02769e4c76977fae7d807c6326d9b4679e319fa84debc9b250d0548e7dcac2e078b4968160490831e2390ce86fbe229 SHA512 2578a594bf9f1b33b5a78bd3e52b9fb73d0457b021a2bca6b5f8d311c0ecb347968a928a1dabd2c8806972dda6ec535fec94d6f792b6f5398aeff587321e5113
+DIST adodb-5.21.0.tar.gz 437724 BLAKE2B addd14c45ec3e1a3fcda63065ccbf06a6627fcf498a3aecc609c7763627915904c241bcb2db1c3aa31ba228b35d788885fd09311e2353f7490e31cee070f607e SHA512 305b5395e4d47d86bbb689818fee44a2b970d081e9ab527f7d0b010b5ae1159eac32c125d5b303569afa2a4360e160c37e17ff7c5adb7566175f9f131393643c
diff --git a/dev-php/adodb/adodb-5.21.0.ebuild b/dev-php/adodb/adodb-5.21.0.ebuild
new file mode 100644
index 000000000000..b7a894acbd32
--- /dev/null
+++ b/dev-php/adodb/adodb-5.21.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="ADOdb"
+DESCRIPTION="Database abstraction layer for PHP"
+HOMEPAGE="https://adodb.org/ https://github.com/ADOdb/ADOdb"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# If you want to be picky, we should require that PHP be built with at
+# least one database driver enabled; otherwise adodb isn't going to be
+# able to do anything. But, the database USE flags for dev-lang/php are
+# a mess. What we would *like* to do is have a set of USE flags for
+# adodb that then propagate to PHP itself... for example, adodb[mysql]
+# could require php[mysql]. To do that would require that we duplicate
+# the database USE flag mess for adodb -- not desirable. Instead we punt
+# and let the user install adodb unconditionally. If he doesn't have
+# database support in PHP, it just won't work.
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ DOCS="README.md docs/changelog*.md xmlschema*.dtd session/*.sql"
+ DOCS+=" session/*.txt session/*.xml pear/auth_adodb_example.php"
+ DOCS+=" pear/readme.Auth.txt"
+
+ dodoc $DOCS
+ rm -f $DOCS || die "failed to remove docs before installation"
+
+ insinto "/usr/share/php/${PN}"
+ doins *.php
+ doins -r datadict drivers lang pear perf session xsl
+}