summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-01-10 17:45:59 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-01-10 17:47:58 +0300
commit37d7bdc340e08e97649558220bd45df7f429ea9b (patch)
tree84ad4afd04391029e0e5ef907a43c2ef5ad539a9
parentmedia-libs/libwebp: amd64 stable (diff)
downloadgentoo-37d7bdc340e08e97649558220bd45df7f429ea9b.tar.gz
gentoo-37d7bdc340e08e97649558220bd45df7f429ea9b.tar.bz2
gentoo-37d7bdc340e08e97649558220bd45df7f429ea9b.zip
dev-libs/xmlrpc-c: revision bump
Respect user CFLAGS, fix building with USE="-cxx". Drop old revision Reported-by: Gilles Dartiguelongue <eva@gentoo.org> Gentoo-Bug: 604440 Package-Manager: portage-2.3.3
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.39.11-cplusplus.patch14
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.39.11-r1.ebuild (renamed from dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild)17
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.39.11-cplusplus.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.39.11-cplusplus.patch
new file mode 100644
index 000000000000..64de06b3bb28
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.39.11-cplusplus.patch
@@ -0,0 +1,14 @@
+--- a/lib/Makefile 2015-12-30 07:22:14.000000000 +0300
++++ b/lib/Makefile 2017-01-10 15:17:39.410000000 +0300
+@@ -9,7 +9,10 @@
+
+ # Build up SUBDIRS:
+ SUBDIRS =
+-SUBDIRS += util libutil libutil++
++SUBDIRS += util libutil
++ifeq ($(ENABLE_CPLUSPLUS),yes)
++ SUBDIRS += libutil++
++endif
+ ifeq ($(ENABLE_ABYSS_SERVER),yes)
+ SUBDIRS += abyss
+ ifeq ($(ENABLE_CPLUSPLUS),yes)
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11-r1.ebuild
index 916292bdddae..e8a106e5a994 100644
--- a/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,10 +27,25 @@ DEPEND="
libxml2? ( dev-libs/libxml2 )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.32.05-Wimplicit.patch"
+ "${FILESDIR}/${P}-cplusplus.patch"
+)
+
pkg_setup() {
use curl || ewarn "Curl support disabled: No client library will be built"
}
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS_COMMON/s|-g -O3$||" \
+ -e "/CXXFLAGS_COMMON/s|-g$||" \
+ common.mk || die
+
+ eapply ${PATCHES[@]}
+ eapply_user
+}
+
src_configure() {
econf \
--disable-wininet-client \