summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 07:11:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 07:35:49 +0200
commit37fa37038cde1f250a762afcd7a582805b4ea753 (patch)
treed02ced519af873ed20875037e0cadebe7b21a131
parentdev-python/cons: Bump to 0.4.6 (diff)
downloadgentoo-37fa37038cde1f250a762afcd7a582805b4ea753.tar.gz
gentoo-37fa37038cde1f250a762afcd7a582805b4ea753.tar.bz2
gentoo-37fa37038cde1f250a762afcd7a582805b4ea753.zip
dev-python/PyGithub: Bump to 1.59.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.59.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index 17bf6064b8f7..b6b6642f41dc 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1 +1,2 @@
DIST PyGithub-1.58.2.tar.gz 3171156 BLAKE2B 251964d542eff68b16a4b56740ed3753f80e56f56458cbc1b909b082b6f5deaf805088a24002e1bb95dae46fc7dcd54da6dbfdbd43c79c097a55f118c0bcc755 SHA512 91db0db09c4bfd145013c4b0861d12271a83bce9de7865eaa3e8baeb02bbb262218987556e7df435b50fcd14ea178da7bc23225d4d93ccf1714fa9a894cd46bd
+DIST PyGithub-1.59.0.tar.gz 3295401 BLAKE2B 39261ddcd20112aa529c17f66c8e69d7af7db9708f179395f29ea4b881fdec4598637b63ca1214affc2f6a9c15db227e57ade51029ed578a6b90633d353712cf SHA512 2a95fb9a99c096a1ee0971df133338764275a9ac99e58a4d81ece954831497e0aaf6eec26172513843098777666ab4f3c5df92a42802f0b953fe50f5ec7824a9
diff --git a/dev-python/PyGithub/PyGithub-1.59.0.ebuild b/dev-python/PyGithub/PyGithub-1.59.0.ebuild
new file mode 100644
index 000000000000..c22ebb71ed44
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.59.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="
+ https://github.com/PyGithub/PyGithub/
+ https://pypi.org/project/PyGithub/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest