summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:47:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:24 +0200
commit3806c0fefbf35e780bef077eda75e4c1ae054000 (patch)
tree39f4ed1e9ab4f9ae1afe3caf452a06aee8acec24
parentkde-frameworks: Add KDE Frameworks 5.61.0 (diff)
downloadgentoo-3806c0fe.tar.gz
gentoo-3806c0fe.tar.bz2
gentoo-3806c0fe.zip
app-office/ledger: Drop elisp-common, make reference in pkg_postinst
Non-maintainer commit. Drop duplicate eapply-user that is already run by cmake-utils. Closes: https://bugs.gentoo.org/691004 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-office/ledger/ledger-3.1.2.ebuild26
1 files changed, 6 insertions, 20 deletions
diff --git a/app-office/ledger/ledger-3.1.2.ebuild b/app-office/ledger/ledger-3.1.2.ebuild
index 15695c673914..264bbc82ca57 100644
--- a/app-office/ledger/ledger-3.1.2.ebuild
+++ b/app-office/ledger/ledger-3.1.2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit check-reqs cmake-utils elisp-common python-single-r1
+inherit check-reqs cmake-utils python-single-r1
DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
HOMEPAGE="https://www.ledger-cli.org/"
@@ -17,15 +17,12 @@ IUSE="debug doc emacs python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="test"
-SITEFILE=50${PN}-gentoo.el
-
CHECKREQS_MEMORY=8G
RDEPEND="
dev-libs/boost:=[python?]
dev-libs/gmp:0=
dev-libs/mpfr:0=
- emacs? ( virtual/emacs )
python? (
dev-libs/boost:=[${PYTHON_USEDEP}]
dev-python/cheetah
@@ -42,8 +39,6 @@ DEPEND="
)
"
-PATCHES=()
-
# Building with python integration seems to fail without 8G available
# RAM(!) Since the memory check in check-reqs doesn't count swap, it
# may be unfair to fail the build entirely on the memory test alone.
@@ -82,8 +77,6 @@ src_prepare() {
|| die "Failed to update info file name in file contents"
mv doc/ledger{3,}.texi || die "Failed to rename info file name"
-
- eapply_user
}
src_configure() {
@@ -108,21 +101,14 @@ src_compile() {
src_install() {
cmake-utils_src_install
-
- use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
}
pkg_postinst() {
- use emacs && elisp-site-regen
-
- einfo
- einfo "Since version 3, vim support is released separately."
- einfo "See https://github.com/ledger/vim-ledger"
- einfo
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
+ elog
+ elog "Since version 3, vim support is released separately."
+ elog "See https://github.com/ledger/vim-ledger"
+ elog
+ elog "For Emacs mode, emerge app-emacs/ledger-mode"
}
# rainy day TODO: