summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-19 10:47:29 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-19 14:55:34 -0800
commit380d0009386c1470f672462375912cf54641ae88 (patch)
treed669d4c61612c0ef623be2d4d855706c1689c297
parentdev-python/spark-parser: Version bump (diff)
downloadgentoo-380d0009386c1470f672462375912cf54641ae88.tar.gz
gentoo-380d0009386c1470f672462375912cf54641ae88.tar.bz2
gentoo-380d0009386c1470f672462375912cf54641ae88.zip
dev-python/sphinx-jinja: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-python/sphinx-jinja/Manifest1
-rw-r--r--dev-python/sphinx-jinja/sphinx-jinja-0.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinx-jinja/Manifest b/dev-python/sphinx-jinja/Manifest
index af901a158c90..1de5ccc4bbf1 100644
--- a/dev-python/sphinx-jinja/Manifest
+++ b/dev-python/sphinx-jinja/Manifest
@@ -1 +1,2 @@
DIST sphinx-jinja-0.2.1.tar.gz 6676 BLAKE2B e009731381dff9aebbfd9ddddc3ce128a6dd172b64ef2610847296b30d2cc4ad5fc71f71d2e1ff5fcf2d0e717b92822bffedc25fbcb6215e072bfe285038a9df SHA512 4b5239c76493f8eabc2a079d82d52b8bb34e884e308aa7e1205cfa40690854ddd1e4c1aee9f7ff0624eee2588a3af9196a83a79f0f49359df315cb0886f09c94
+DIST sphinx-jinja-0.3.0.tar.gz 7035 BLAKE2B a43c2ab6c1f0178987ccf9f69acbf0b50974573b83d0503e7888a56bf024e519ad69e3ac6ec9b8d27d7e01e9482008b6579c6892ce114124c0ef12ef456c887c SHA512 b39211a0013db020112c865335811317699e7ade734bfd9bb24f51934df4652f0560b81f5e253fc663fbd8a269fd962ef2bfd6dc96eab12a397a538e758cddfd
diff --git a/dev-python/sphinx-jinja/sphinx-jinja-0.3.0.ebuild b/dev-python/sphinx-jinja/sphinx-jinja-0.3.0.ebuild
new file mode 100644
index 000000000000..df6366a639de
--- /dev/null
+++ b/dev-python/sphinx-jinja/sphinx-jinja-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension to include jinja based templates into a sphinx doc"
+HOMEPAGE="https://github.com/tardyp/sphinx-jinja https://pypi.python.org/pypi/sphinx-jinja"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ if python_is_python3; then
+ sed -i -e "s/import urllib/import urllib.request as urllib/" sphinxcontrib/jinja.py || die
+ fi
+}
+
+python_test() {
+ nosetests || die
+}