summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-02 13:59:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-02 13:59:31 +0100
commit3824dc89d7d98dee12013ae0422ec9fa51b55cc1 (patch)
treeb6a7a08a3ac047502ce8332a9de0df5225aa47f8
parentxfce-extra/xfce4-notifyd: Remove old (diff)
downloadgentoo-3824dc89d7d98dee12013ae0422ec9fa51b55cc1.tar.gz
gentoo-3824dc89d7d98dee12013ae0422ec9fa51b55cc1.tar.bz2
gentoo-3824dc89d7d98dee12013ae0422ec9fa51b55cc1.zip
app-vim/gentoo-syntax: Bump to v12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-12.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 381c57a23d59..f32801e47ead 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-11.tar.bz2 20986 BLAKE2B dd4d4d3a65480a4600d9c1372fdb1db40c07d3a954232513a535cd9e7d59e5e89f185e32aa7bfe38909e1ef4b0e2639136478ba9ab7eb6ceedd9fdb459b08da2 SHA512 9c74b38880429e2e980e8f44b51ed5bc3bb1431d8429a7ac66574556e3ca01e909c445585da9152d78e38d23cc9a4c100bb81f56ea8c0b63291b8df0dca7b886
+DIST gentoo-syntax-12.tar.bz2 21022 BLAKE2B 758993282ccc26384bb1fc761f2a07059d5e2e7038f56d48ec19ac82ddecb7cd1601fbdd4221e6b41b43281195d862c93d98c12c47d2d43f4a6cbb4784ae6b46 SHA512 07bc7102b3f687c53d8e46c5ca91c1d605239490f160c6db11c6d17ae95b94d34e9ac654b3c9935099382f39ba8b92ea373b09f86fc6452840d12f135820b2b3
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-12.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-12.ebuild
new file mode 100644
index 000000000000..8465cb7009c6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}