summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-08-27 10:32:17 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-29 13:35:08 +0300
commit382ebcd415df01ea5262f1286f85faeafd85c4e4 (patch)
tree4c702df1e351a182cd78c98d1d94797f4567b0c0
parentnet-im/profanity: add use flag to add support of python plugins (diff)
downloadgentoo-382ebcd415df01ea5262f1286f85faeafd85c4e4.tar.gz
gentoo-382ebcd415df01ea5262f1286f85faeafd85c4e4.tar.bz2
gentoo-382ebcd415df01ea5262f1286f85faeafd85c4e4.zip
net-im/profanity: add two upstream patches
profanity-0.14.0-ox-carbons.patch: Fix wrong display of ox carbons. profanity-0.14.0-xscreensaver.patch: Fix spamming of logs when no X is running. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/32471 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-im/profanity/Manifest2
-rw-r--r--net-im/profanity/profanity-0.14.0-r1.ebuild15
2 files changed, 15 insertions, 2 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 419a75ddcd5f..626af351c308 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,2 +1,4 @@
DIST profanity-0.13.1.tar.xz 621836 BLAKE2B e038fa01272150cb7974b03f88f64335bf1690115dbbb1c6fe04c79acb69db18c556edf41316af1d363f9715cd2e7aeb3f3bd867836704b620d9a87976b64fa9 SHA512 6d7d3c96c65e26c15cac1157bd296c1dbd3e2471aec959d6c319c68b70ec21cef0c40d7b4eed40c30c377a766db9f13a774ccb4880c227ee368e4dd607d9c267
+DIST profanity-0.14.0-ox-carbons.patch 1525 BLAKE2B 85fe9a76a8c735047365d56555c8e1df7906b5a676740a165fc5d9eab3933124b58abf6bdd0b448b5030a51cd1fad3ce8627cc03a2fbdacdd20c5dcc71d194e1 SHA512 36cfbb12ef7889ae5f318e35da2b0edf39dca067cefb9ac921f27cba0f52746eaae9d65b7631be392dd6e9a15d1fc8f8a3de36efe8707c756e9b008291e7f55e
+DIST profanity-0.14.0-xscreensaver.patch 1678 BLAKE2B fe350b2249e45224b6510bb5730f38eafeb47e60a44035eaf88771940c9f0e556cc72ca737cb68c0b148b9faff442b9c9b6cdf9169a3db7ff6c7a60c2bdfc025 SHA512 2875df728b9957fc3bc8734a87c0e1a48913170b9718d6664ea65187327e26da1a7b2f5b80fe243a5ce5ab74983e4f3d22113747f44f8b8e8c13c871d31cf651
DIST profanity-0.14.0.tar.gz 936272 BLAKE2B ec2ae625950a838ee50d6d3a87910bec76f28777bd662e909f394f18c277662694611a59d3be6c7f66821c2800a94b08f94b27a68d82e4de33b7d2f7b14ddf18 SHA512 25afd2f3146e6ed9f573f0e073cad0f06f7f8a21441c3c2c61641442d1aa5b9a7a817cdccc17354b32045ab9a965a95495a30c49088577a5060e8969725ea86e
diff --git a/net-im/profanity/profanity-0.14.0-r1.ebuild b/net-im/profanity/profanity-0.14.0-r1.ebuild
index 537409d27d05..f5c591413f3e 100644
--- a/net-im/profanity/profanity-0.14.0-r1.ebuild
+++ b/net-im/profanity/profanity-0.14.0-r1.ebuild
@@ -3,12 +3,18 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit python-single-r1
DESCRIPTION="A console based XMPP client inspired by Irssi"
HOMEPAGE="https://profanity-im.github.io"
-SRC_URI="https://github.com/profanity-im/profanity/releases/download/${PV}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/profanity-im/profanity/releases/download/${PV}/${P}.tar.gz
+ https://github.com/profanity-im/profanity/commit/122434a.patch
+ -> ${PN}-0.14.0-ox-carbons.patch
+ https://github.com/profanity-im/profanity/commit/2ed6211c.patch
+ -> ${PN}-0.14.0-xscreensaver.patch
+"
LICENSE="GPL-3"
SLOT="0"
@@ -55,6 +61,11 @@ DEPEND="
)
"
+PATCHES=(
+ "${DISTDIR}/${PN}-0.14.0-ox-carbons.patch"
+ "${DISTDIR}/${PN}-0.14.0-xscreensaver.patch"
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}