summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 09:14:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 10:07:14 +0200
commit383321e3ff298a336bba858f2e202e854fcfa6f6 (patch)
treeb457ee13f9b5468b0e3e718038da7837ac4ab264
parentdev-python/pyenchant: Enable py3.11 (diff)
downloadgentoo-383321e3ff298a336bba858f2e202e854fcfa6f6.tar.gz
gentoo-383321e3ff298a336bba858f2e202e854fcfa6f6.tar.bz2
gentoo-383321e3ff298a336bba858f2e202e854fcfa6f6.zip
dev-python/sphinxcontrib-spelling: Bump to 7.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 1dacedae960e..1572910454db 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-spelling-7.3.2.tar.gz 51813 BLAKE2B 7c96f3b102fa33ea4d9e35100930a157200a1c01c51d8ec5145c45c5a24e3b5de35f6c4669177363c6098cb96275e10c39ff660c36d209cb6fa658e50cb8e169 SHA512 043a50f694366de4a3aedc24ca2ea7d89c85087097264f4e4fc860f68a3df5a67f19ec7172e4a67074377846d013d24edecd751885136c7263bc30b034c0f0e9
DIST sphinxcontrib-spelling-7.3.3.tar.gz 51912 BLAKE2B 6a9bd90db2298beb78686252d555dd5e77d0c9042eb0986dd2eeab9e413a921c5f5f594c539c2cfe6315002c2f2892241b789b10976e634158f3ca1d8be1b627 SHA512 7406bd846c5eac507f8e4481ada4d0d725d0a3ad8cf2f8fd3328389128cf54091bb0e304dfe23fdf771a26d9103d2c028d2f7f29e1949ca59fcf43de5bac9cb1
+DIST sphinxcontrib-spelling-7.4.0.tar.gz 52966 BLAKE2B d0dbb6a5ae704f8cc8eaf0a73455b1ae044d68e34c723f1368899f7d7567c0e77a5279f333c710017ed00c53f7eb9a977f6a803b87b03fbf2b78e0be02bd1ac0 SHA512 27edbde0ad7d9321ceda9263e2139421578c48f82bad04c51359134ae89631ddfcf27ac5bdb1d012354e71020be373c8017550c5db73fdccb912d4ab10d223c8
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.4.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.4.0.ebuild
new file mode 100644
index 000000000000..834977197c58
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}