summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-09-02 21:06:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-10-15 13:52:40 +0300
commit383a38acb658bafa5079f7c01827fa973738a8e4 (patch)
tree2f93997369feb09ee36b6cc6a9b1cbdee25f0425
parentwww-apps/hugo: fix failing test with newer libwebp (diff)
downloadgentoo-383a38acb658bafa5079f7c01827fa973738a8e4.tar.gz
gentoo-383a38acb658bafa5079f7c01827fa973738a8e4.tar.bz2
gentoo-383a38acb658bafa5079f7c01827fa973738a8e4.zip
www-apps/hugo: drop 0.99.1
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.99.1.ebuild94
2 files changed, 0 insertions, 96 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 5cefacfd7353..1041d1b077c1 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -1,5 +1,3 @@
DIST hugo-0.101.0-libwebp-1.2.3.patch 5197 BLAKE2B ef39ae1d804a96f791031eef87f1e0a51ccf0abc2963c65bb0e86971d0a5079445707af57d14f98c9709a97e148925cb51b676d4009e89b7ff695e633b200443 SHA512 3c8b227f07037048f0191b7ecda1d6c3900b2b515ae2007cbc18d8c9b8d8dd10f70e7b41dd8b81c612c43ae280024538226cd93049c20e9437e774c28b51b45a
DIST hugo-0.101.0-vendor.tar.xz 5682852 BLAKE2B 130cf9fda4d857e69144147e408a90fd28273d42919c4ea50228b795b7c35f9641857f642be8628b947b213ee42f11f468ca76317d4742d09c60bc5a272e83ff SHA512 07390ebb9daf2097010013f5e7c789f3fcee485952968b0934cc5d625eec9a79784ccda1414e59a21073b66389c75888704f923675f255df5eaa0d43c0cc3048
DIST hugo-0.101.0.tar.gz 28130925 BLAKE2B ff35c48c39dac61abe56ba4f75bfddcdda700b71157dc4ed75f1c3724b11b8a9f4546e94d3105a724a5493b3baa73056a55d9d90e87ce4237e39213995db636d SHA512 541d0e04e868845119f2b488fd53b92929ea4dc08685d438a2914b41586e204588b193522013e8eed908dc0c3fbc2714aefb1afad0beae875d57d71aadc59c70
-DIST hugo-0.99.1-vendor.tar.xz 5675228 BLAKE2B 80fdd25fe924bcde7f200b805bf6598dbb726bb628b82e9b0d2809414a7a6e33cbfe069e29953e75b8ed4ecdb9c7303b44a8d8195b43540977cd7461295de109 SHA512 88ffb6bea777e3a72dac05941de542acdc6a17faff9e98517e483e17c7a42d1ab5aa7e65ed3a91f6832468d2da3e98e87346118694a8e20f6375fad56d5d7ff0
-DIST hugo-0.99.1.tar.gz 27721831 BLAKE2B 951840055b345f87cca287ad6391787290296dab44ba2295a49e98c6e93ecb344e9591137e8fdd34d7182e2ec334e36b5ff5ebfd17c3f973dbe31d9444d7bf38 SHA512 cebdad62493b1f734fd0346d94f1480a597ea38bf984d8e91a2ae63a4083c1671d81f289a4396a1e1a2c973c8733eba95623dd7d50c31b8c4b096576a06ae03b
diff --git a/www-apps/hugo/hugo-0.99.1.ebuild b/www-apps/hugo/hugo-0.99.1.ebuild
deleted file mode 100644
index 16dbceafb579..000000000000
--- a/www-apps/hugo/hugo-0.99.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 2018-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Fast static HTML and CSS website generator"
-HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
-SRC_URI="
- https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
-"
-
-# NOTE: To create the vendor tarball, run:
-# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +sass test"
-
-BDEPEND="
- >=dev-lang/go-1.18
- test? (
- dev-python/docutils
- dev-ruby/asciidoctor
- virtual/pandoc
- )
-"
-RDEPEND="
- media-libs/libwebp:=
- sass? ( dev-libs/libsass:= )
-"
-DEPEND="${RDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch"
- "${FILESDIR}/${PN}-0.96.0-skip-some-tests.patch"
- "${FILESDIR}/${PN}-0.99.1-fix-testdecodeconfig-basic.patch"
- "${FILESDIR}/${PN}-0.99.1-test-timeout.patch"
-)
-
-src_configure() {
- export CGO_ENABLED=1
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
-
- MY_BUILDFLAGS="$(usev sass "-tags extended")"
-
- default
-}
-
-src_compile() {
- mkdir -pv bin || die
- ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
- ${MY_BUILDFLAGS} -o "${S}/bin/hugo"
-
- bin/hugo gen man --dir man || die
-
- mkdir -pv completions || die
- bin/hugo completion bash > completions/hugo || die
- bin/hugo completion fish > completions/hugo.fish || die
- bin/hugo completion zsh > completions/_hugo || die
-
- if use doc ; then
- bin/hugo gen doc --dir doc || die
- fi
-}
-
-src_test() {
- ego test -race "./..." ${MY_BUILDFLAGS}
-}
-
-src_install() {
- dobin bin/*
- doman man/*
-
- dobashcomp completions/${PN}
-
- insinto /usr/share/fish/vendor_completions.d
- doins completions/${PN}.fish
-
- insinto /usr/share/zsh/site-functions
- doins completions/_${PN}
-
- if use doc ; then
- dodoc -r doc/*
- fi
-}