summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-11-02 06:31:25 +0100
committerHans de Graaff <graaff@gentoo.org>2019-11-02 06:31:25 +0100
commit3842de3b96eef3c9a442cb226cde19967ac5d59a (patch)
tree6267ae33fa82be0d970a03213050f6c62ecb05cc
parentdev-ruby/rack-attack: add 6.2.1 (diff)
downloadgentoo-3842de3b.tar.gz
gentoo-3842de3b.tar.bz2
gentoo-3842de3b.zip
dev-ruby/rjb: add 1.6.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rjb/Manifest1
-rw-r--r--dev-ruby/rjb/rjb-1.6.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-ruby/rjb/Manifest b/dev-ruby/rjb/Manifest
index 9f89d8afbb0c..b602888506b8 100644
--- a/dev-ruby/rjb/Manifest
+++ b/dev-ruby/rjb/Manifest
@@ -1,2 +1,3 @@
DIST rjb-1.5.5.gem 73216 BLAKE2B 3bee34d033e5d85150740df1e30d93d54a3078824c76535e1300d2be0a2ecfc6aac2b30762a6b85fd1449df45b49550c0627f6cd588af712d0dfdaab2ca4e68c SHA512 a1a8f6e6b75555ce228fe8d58b467f783e55ddb12371485d45ad32597ea7ec60d30e3870671455e4e22fd680b5aa21bd952b8abfa36531c030747573e5d43cea
DIST rjb-1.5.7.gem 72704 BLAKE2B 9a4f2b304c05f65c0d78ca4909814da366de717f518017c73d23cfcf188d653141d6c4549200c4bd3e55421f59cf8442cf2d01c1c5c1be813964ee7fb4a7b501 SHA512 0ccdbb5bc6f9f5d914d5b117c96310d709965b81a4bd2d0d7c428aabf4e32672572d4187660bc1b509fa3c92ac4cbe97cbd98412253d4ec9a7e4981f3b7a3131
+DIST rjb-1.6.1.gem 74240 BLAKE2B 103e3885634be9c7dd842c2737c420511fea04e4e2d18f77dba7689c47da996fa37af5d08827de21ec38effd3fd99407e99491c8b99d134dded219ccf3880b79 SHA512 5b78fc4eabceddeb901145af39b1fc76e9a44801596ea4bacf9ce601cc109107cf042b1aa4c27049abd766ffca3206364079866ce7b88d25657fa75e7593adc3
diff --git a/dev-ruby/rjb/rjb-1.6.1.ebuild b/dev-ruby/rjb/rjb-1.6.1.ebuild
new file mode 100644
index 000000000000..b8cfe20bb7cf
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.6.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit java-pkg-2 ruby-ng ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="https://github.com/arton/rjb"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.5
+ hardened? ( sys-apps/paxctl )"
+RDEPEND="virtual/jre"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+all_ruby_prepare() {
+ # The console is not available for testing.
+ sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
+
+ # Avoid encoding tests since not all locales may be available.
+ sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # currently no elegant way to do this (bug #352765)
+ ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+each_ruby_test() {
+ if use hardened; then
+ paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
+ if [ $? = 0 ]; then
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ else
+ ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
+ fi
+ else
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ fi
+}