summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-01 04:41:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-01 05:01:22 +0200
commit3848fb8a987852a39d1950dcefc18318f5ecd33d (patch)
treeecd8d2f70ed099699a5f76c80b2fa7f892db2e2f
parentdev-python/rich: Bump to 13.5.1 (diff)
downloadgentoo-3848fb8a987852a39d1950dcefc18318f5ecd33d.tar.gz
gentoo-3848fb8a987852a39d1950dcefc18318f5ecd33d.tar.bz2
gentoo-3848fb8a987852a39d1950dcefc18318f5ecd33d.zip
dev-python/sentry-sdk: Bump to 1.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.29.0.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 615c5b3d3186..126b8ce11c08 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -2,3 +2,4 @@ DIST sentry-python-1.26.0.gh.tar.gz 371531 BLAKE2B cdc44a8c4067405242b7aaec28999
DIST sentry-python-1.27.1.gh.tar.gz 376598 BLAKE2B 4ad5986af5e252cf501523fcafdaa7ada4870aae0252227907d86ce3e886b58f7154f4407cb6ae22473044589c9c2639c7de8ca92dea1a7a7835c51c28b44bb6 SHA512 1408c06b3b8a8ef0c888f26a4591d45b63fda51853e52f2ea8921e4983d0a7b05b053c6bf17d55fc59667e5b4b4ca953419303774101fa58ef6f37428d600c90
DIST sentry-python-1.28.0.gh.tar.gz 378626 BLAKE2B 826257c5cae7d1f58753d4a84fb7aeb0fb9d52690a660615590cdd34c7d1afe1e256291d9434f904644292d6ab379fcad03cc7d8b1072e3b41b03fb5e4961db6 SHA512 83ceecbf89f197c03b0a402508c677eed4c6adb36ff826579513f79dd36c666e47267c7b6e8f4eced91fc12b18a0de3c1a24c89c6fe6e77c603ace535612542c
DIST sentry-python-1.28.1.gh.tar.gz 379559 BLAKE2B 715f6a1756de85f7c041098f2bea94e02e61b433f55cbccca2b23455ee1c43312cae8a468443877113eb2ae2da8515f07b2aa08a29358ef1fd6b564bcc8bc329 SHA512 28ef182f4f7945c5499d7206a19a8ac90440031785bd4065259dcaefc9e7cd7ddad423ec61db954fc3936ed3fccec9e4bc136bb278407704579f3b97f4ff4aa6
+DIST sentry-python-1.29.0.gh.tar.gz 387456 BLAKE2B 5ebd9901a2e60cfd4c688c32e045e1a05d227608eaecfb3de3049cf608d631fc70aa5fb7dba9085b4ba1bc5fe648f52d1f1a549aa67a39ddbe3e7f67d4f38d73 SHA512 a08da9ed5e8107a6f364868922aa8eadebbef62acdd51407684861280053d63a766b3e7bd689a80ea8083ea28ac30140b46b3de163490edf62b50717086fc59d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.29.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.29.0.ebuild
new file mode 100644
index 000000000000..1335788113ac
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.29.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
+ tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
+ tests/test_scrubber.py::test_span_data_scrubbing
+ # this is not even funny
+ tests/integrations/modules/test_modules.py::test_installed_modules
+)