summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-09-02 10:07:38 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-09-02 10:07:38 +0100
commit385eab51e5b5896e402e36aba023aee41d6ddd0b (patch)
treeb1d306cc6c3ca41fa5668020c7416c84fe947f7e
parentdev-cpp/sdbus-c++: Bump systemd version for 0.9.0 (diff)
downloadgentoo-385eab51e5b5896e402e36aba023aee41d6ddd0b.tar.gz
gentoo-385eab51e5b5896e402e36aba023aee41d6ddd0b.tar.bz2
gentoo-385eab51e5b5896e402e36aba023aee41d6ddd0b.zip
sys-firmware/firmware-imx: Version bump to 8.17, EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--sys-firmware/firmware-imx/Manifest1
-rw-r--r--sys-firmware/firmware-imx/firmware-imx-8.17.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/sys-firmware/firmware-imx/Manifest b/sys-firmware/firmware-imx/Manifest
index 1be082a21c9b..405fccd11d5d 100644
--- a/sys-firmware/firmware-imx/Manifest
+++ b/sys-firmware/firmware-imx/Manifest
@@ -1 +1,2 @@
DIST firmware-imx-5.4.bin 429744 BLAKE2B a573f14d2c7cb35a1129bf5b1ebc31126ebb23b4a5d4ba407ddb432148d34f27e94990ca2b8dbe6083905f3504ca3db19966283b33657e2a2b0b5ed4cd8c0c79 SHA512 0c9d6e80a67d15518212573dbfe8addd6c7c5c8065f077bb58f6904c6d288c718d0b3dc4ed4735941d22bc9116a4986fb268327e2c1adcc6523ff84fa93c6b64
+DIST firmware-imx-8.17.bin 1460231 BLAKE2B 17d790052015675aa972d312f4b8d8dab2d167f48cdd880b31b7bf52f79882bbb1bdfb8fcf49d0b6f41f3cd7c5b88963ea7034ed45e35f9c8db16873fc90ed23 SHA512 88c0866354175bb7b54b15ef58e41e3c51e63ea9eeb1cef1c91cdf180a52e97fb755428180df84bee2e9f0dce9633fb663d4f68caa6c327fb2a3fe508dc4cdf9
diff --git a/sys-firmware/firmware-imx/firmware-imx-8.17.ebuild b/sys-firmware/firmware-imx/firmware-imx-8.17.ebuild
new file mode 100644
index 000000000000..30bb93a7b840
--- /dev/null
+++ b/sys-firmware/firmware-imx/firmware-imx-8.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NXP i.MX firmware"
+HOMEPAGE="https://www.timesys.com/"
+SRC_URI="http://repository.timesys.com/buildsources/${PN:0:1}/${PN}/${P}/${P}.bin"
+LICENSE="LA_OPT_BASE_LICENSE"
+SLOT="0"
+KEYWORDS="~arm"
+
+S="${WORKDIR}/${P}/firmware"
+
+src_unpack() {
+ eval local $(grep -a -m1 "^filesizes=" "${DISTDIR}/${A}")
+ tail -c"${filesizes}" "${DISTDIR}/${A}" > "${P}.tar.bz2" || die
+ unpack "./${P}.tar.bz2"
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r epdc sdma vpu
+}