summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-31 07:49:38 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-31 07:49:38 +0100
commit386ca1c70093064a5127a917debf1679ce727260 (patch)
tree16728d2c39c70702c806542703fa1e1b03a1074e
parentdev-python/xdoctest: Bump to 1.1.3 (diff)
downloadgentoo-386ca1c7.tar.gz
gentoo-386ca1c7.tar.bz2
gentoo-386ca1c7.zip
dev-python/pyfakefs: Bump to 5.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.3.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 3b0126ee9321..1b698b4ba2e3 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,2 +1,3 @@
DIST pyfakefs-5.3.2.gh.tar.gz 225929 BLAKE2B 1a84f52e8d85b55d2ebc0dcf9c4b44bd053c0a3a12d6c47c1f8d5aec304e39a83ffb01d4c707929955ca5cd86ae9427332d5bf043cb7f910fe1d17fbcc19e35c SHA512 4cc2c861fa358c06832df6e8a7cfc91e2b9be42f1164378ea6bd0a3a6cc48f36c545b7d61e03591d025ef7bd98fdc812f903973f28a278056961aec22ca88641
DIST pyfakefs-5.3.4.gh.tar.gz 226538 BLAKE2B b0cac2799c7d9517a1fc89d15cf92222dc5d5438ba4c43bc8796afbf77c2c7a2729bf42e1b57b1fb3777a91aa0fa12e0d6a0a6e0068855fba86bf6e372bac28e SHA512 10c56af0b871b8b8ce483d01234ebba953b038fd030edf4f0fedcb5b23ee897c912d9e9404521ec11f9e8d0d041d4bde4f101a4d99b3b527721c4c291c2a6745
+DIST pyfakefs-5.3.5.gh.tar.gz 227359 BLAKE2B 635e41cb9892e1707555559769c01d5b575e44c5f1dd412acc05c3bed3b2dad2724ba32341b59cdecdfb658c94008e09396970349d8c1ffdcb90bf89ea82aca0 SHA512 342dc9cc0378af8cd8a9b0783fb6a1415207505ec8d4992f8fdd7e8d2bc4aada26d0803ed3b74d30b42a50dffb793c70acdeb3f28f199c0918783e1ea0a5e0d8
diff --git a/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild b/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild
new file mode 100644
index 000000000000..754709257053
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ # test for regression with undefined package
+ pyfakefs/pytest_tests/pytest_fixture_test.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}