summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-11 20:40:15 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-11 21:10:06 +0200
commit38886a5681a9f9e93897834878dfca2a399317d7 (patch)
treec8799768628feeef50af04bc99177d26fae1ae5f
parentgnome-base/gnome-desktop: remove old (diff)
downloadgentoo-38886a5681a9f9e93897834878dfca2a399317d7.tar.gz
gentoo-38886a5681a9f9e93897834878dfca2a399317d7.tar.bz2
gentoo-38886a5681a9f9e93897834878dfca2a399317d7.zip
dev-python/argon2-cffi: add 21.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/argon2-cffi/Manifest1
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/Manifest b/dev-python/argon2-cffi/Manifest
index 4674fd4a5257..4e1351bfbb5e 100644
--- a/dev-python/argon2-cffi/Manifest
+++ b/dev-python/argon2-cffi/Manifest
@@ -1,2 +1,3 @@
DIST argon2-cffi-21.1.0.tar.gz 1807800 BLAKE2B 47b1e785b7eb173b671a44e9212af76a59f453c3c0d0e5f2c437e7a62132abf86ab6baa8bdd656ad28d00a151296a66211d365c0afe228821c8c1ff1a0a66c46 SHA512 bbfebd2c075f360a6c1c187c0789be2aae7480b9398f36db7bdfe74f288d9e00b44a788918c54f4cc8bb1947136ab0493f61975de408c482a5131e2bf1a8f4d0
DIST argon2-cffi-21.2.0.tar.gz 42399 BLAKE2B d2f1a7e7caf776239f343f5e5f2cd1fcd78f0dbdfc28814e3299df18e5c97a81cafa37bf10733614fe32ddc8d19fa5c5721285e8b96b9172eaf2322a5bb9e529 SHA512 40cdd18106d959bf58f20a35ea84ac3c3859d28ed6cfa28ee81655c12038b4e0f28bfe2d8ee9b96cd6009dfcebe0ef6aa4eb7fa9cd81cad0b32911ca723a8bdd
+DIST argon2-cffi-21.3.0.tar.gz 38446 BLAKE2B e0464f501efcdfbf33d93e0c1c6dbc519ad6aee06c0b8692417156de608f6c6acf947f86b866c064601fe994087677e51d954ae2c1225cbbbba3534cf70c6296 SHA512 6cb2a075f3bb7040ee7f552d082bfa2f3df0854649d9c84fdfdb42bb4bee2133b8a35a20be2b3c887931efda12fbbb00815d8d88170b7e20b3ca19c86f97057e
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild
new file mode 100644
index 000000000000..3a28d9718394
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst FAQ.rst README.rst )
+
+src_prepare() {
+ # Patch the tool.flit.module.name entry in pyproject.toml to include
+ # the "src" subfolder. This allows pyproject2setuppy to retrieve the
+ # dynamic version and description correctly.
+ sed -i -e 's:^name = "argon2":name = "src/argon2":' \
+ "pyproject.toml" || die "Unable to patch package name"
+ # Sphinx's conf.py uses importlib.metadata to determine the package
+ # version. However, argon2-cffi is not installed when we try to build
+ # the docs. Therefore, we patch the release version in conf.py.
+ sed -i -e "/^release/s:= .*:= \"${PV}\":" \
+ "docs/conf.py" || die "Unable to patch version in docs"
+ distutils-r1_src_prepare
+}
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-notfound-page
+distutils_enable_tests pytest