summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-01-20 10:42:37 +0000
committerMarek Szuba <marecki@gentoo.org>2023-01-20 10:42:37 +0000
commit388de776aacf55f6e3f095759001fad816fec74e (patch)
tree338c3f43ac340e171cc461b092387240e0aa67de
parentapp-crypt/yubikey-manager: add 5.0.1 (diff)
downloadgentoo-388de776aacf55f6e3f095759001fad816fec74e.tar.gz
gentoo-388de776aacf55f6e3f095759001fad816fec74e.tar.bz2
gentoo-388de776aacf55f6e3f095759001fad816fec74e.zip
x11-terms/rxvt-unicode: add 9.31
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--x11-terms/rxvt-unicode/Manifest2
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.31.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/Manifest b/x11-terms/rxvt-unicode/Manifest
index 9def648f8736..38f3890c3396 100644
--- a/x11-terms/rxvt-unicode/Manifest
+++ b/x11-terms/rxvt-unicode/Manifest
@@ -1,2 +1,4 @@
DIST rxvt-unicode-9.29_24-bit-color_aur-9.26-20210712.patch.xz 7568 BLAKE2B 8ea5d813e00fd4012d145acf70e3d9b0974dddffd203fbec4bf06a0da1c9368ec316fc2903dccae3a5d71d684fd93b2a09ed208f26be1e85f77c702494db4e54 SHA512 baa226ca9adf6025a72dea925ec3be16186502bb4aab21dd61ef1f7c3e2eb793e7a1dc9619ed8228166758daa2879a465da2ace3f3b14545808955388bd2b74b
DIST rxvt-unicode-9.30.tar.bz2 877186 BLAKE2B 645164e37e9e484c66f5047836689e4e4727575dfdcbefc64affb70d9110497529fdcc7d476f77737efed5cee4af314e1e1ccbcb42b506bb7e653b827c24a0c7 SHA512 048d5f635a61bc1a739d5cbc09e7a9f77cee18c81df468ce1ff0a62866ced06fc4ec258bb015d2484a7e7bad2339f0bdd79bd824d649c2553a80bdef9f199e99
+DIST rxvt-unicode-9.31.tar.bz2 880148 BLAKE2B 439a8c33b7260e0f2fd68b8a4409773c06c3bb7623b5dfbbb0742cc198c9fd25e8a247907878639db5fac3dcd3b6be3d839347787bcf08ca602ae246607f750b SHA512 4d14ecbbb62de1b1c717277f5aae5cfb536e11392f2d4b82c884c1713f437fce8e9dd69a328fa353a55d068d8ee4121a31900f45191acec172d5dc76652b6255
+DIST rxvt-unicode-9.31_24-bit-color_aur-9.31-20239117.patch.xz 7776 BLAKE2B 88c12e2db38991fc6c7909950aade09a8c089d93980535af5a602d40cb4712aaa97f659c67e49b52abb71e6d0e2b8279f3d9a6d66654cdf68dde68bf64279873 SHA512 dfc0388138f35345c0c80df0a392c28a52a03d008ca336999369522031898813046c314c1e4ec9a81fea41b81d3230f5ca09d47b84ef04c0f6da98c559812a16
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.31.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.31.ebuild
new file mode 100644
index 000000000000..874b4d6a452c
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.31.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop systemd prefix
+
+COLOUR_PATCH_NAME="${PN}-9.31_24-bit-color_aur-9.31-20239117.patch"
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${COLOUR_PATCH_NAME}.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="24-bit-color 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ perl startup-notification unicode3 xft"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r6:=
+ dev-libs/libptytty
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ perl? ( dev-lang/perl:= )
+ startup-notification? ( x11-libs/startup-notification )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+)
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
+)
+
+src_prepare() {
+ default
+
+ # Current patch is too aggressive to apply unconditionally, see Bug #801571
+ if use 24-bit-color; then
+ eapply "${WORKDIR}"/${COLOUR_PATCH_NAME}
+ eautoreconf
+ fi
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
+ # use xsubpp from Prefix - #506500
+ hprefixify -q '"' -w "/xsubpp/" src/Makefile.in
+}
+
+src_configure() {
+ # --enable-everything goes first: the order of the arguments matters
+ local myconf=(
+ --enable-everything
+ $(use_enable 256-color)
+ $(use_enable blink text-blink)
+ $(use_enable fading-colors fading)
+ $(use_enable font-styles)
+ $(use_enable gdk-pixbuf pixbuf)
+ $(use_enable iso14755)
+ $(use_enable mousewheel)
+ $(use_enable perl)
+ $(use_enable startup-notification)
+ $(use_enable unicode3)
+ $(use_enable xft)
+ )
+ if use 24-bit-color; then
+ myconf+=( --enable-24-bit-color )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die
+}
+
+src_install() {
+ default
+
+ systemd_douserunit "${FILESDIR}"/urxvtd.service
+ systemd_douserunit "${FILESDIR}"/urxvtd.socket
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}
+
+pkg_postinst() {
+ if use 24-bit-color; then
+ ewarn
+ ewarn "You have enabled 24-bit colour support in ${PN}, which is UNOFFICIAL and INCOMPLETE."
+ ewarn "You may or may not encounter visual glitches or stability issues. When in doubt,"
+ ewarn "rebuild =${CATEGORY}/${PF} with USE=-24-bit-color (the default setting)."
+ ewarn
+ fi
+ if use perl && ! use fading-colors; then
+ ewarn "Note that some of the Perl plug-ins bundled with ${PN} will fail to load without USE=fading-colors"
+ fi
+}