summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:02:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:54 +0300
commit38abedf9fbd9c933c3f0c231eda6625278946730 (patch)
tree531df8c6d4e55f82e3062d0deadedadd15fd7a74
parentdev-python/black: add 22.8.0 (diff)
downloadgentoo-38abedf9fbd9c933c3f0c231eda6625278946730.tar.gz
gentoo-38abedf9fbd9c933c3f0c231eda6625278946730.tar.bz2
gentoo-38abedf9fbd9c933c3f0c231eda6625278946730.zip
dev-python/vcrpy: add 4.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 33a6913fe413..dff64dec5c8f 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1 +1,2 @@
DIST vcrpy-4.2.0.gh.tar.gz 331096 BLAKE2B dccb9310da42c6f75d0d503cb64aa09876447098bff2ad6a1507a0e0907ce05a89d46ccc159e79f310e027fc8f3075b7474274ad39ca4778acbc6d2a8f633004 SHA512 61eeec585fc78be1ae6d4f9047123c9680611e436bb5980fb7c6b885e16b2ef9bd5ce921efff7e87a222b3662c7009dbf0a8df24cdb9849d09deb24957ba4889
+DIST vcrpy-4.2.1.gh.tar.gz 331180 BLAKE2B 345e4c148963e2109d02be4e96986083236bd29fa8049c7cc54483f12d0506cde5c116b6f2fe80e099599b22a73e2f6240f7bb91e4a7d8af7f4e8e741097160d SHA512 59231e5164cda3099b18d099f0ef97e062e6401e52e5dfc4022aa89ca02881e9e6e3c782f12c288f5281b3b3bf175dc33a267bc6d2b40791582a1221f5d7aaab
diff --git a/dev-python/vcrpy/vcrpy-4.2.1.ebuild b/dev-python/vcrpy/vcrpy-4.2.1.ebuild
new file mode 100644
index 000000000000..8f48fb71765f
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-4.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests require Internet
+ tests/integration/test_aiohttp.py
+ tests/integration/test_boto.py
+ tests/integration/test_httplib2.py::test_effective_url
+ tests/integration/test_httpx.py
+ tests/integration/test_urllib2.py::test_effective_url
+ tests/integration/test_urllib3.py::test_redirects
+ tests/integration/test_wild.py::test_amazon_doctype
+ tests/integration/test_wild.py::test_flickr_should_respond_with_200
+ tests/unit/test_stubs.py::TestVCRConnection::testing_connect
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest
+}