summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:32:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:50:17 +0200
commit38babfee16ab1c8ce57bed8d84fc00b452d77bef (patch)
tree50c62917291da4f53fd3b4d4d6c3b0f99617b5fb
parentsys-fs/jfsutils: rev bump (diff)
downloadgentoo-38babfee.tar.gz
gentoo-38babfee.tar.bz2
gentoo-38babfee.zip
sys-fs/jfsutils: migrate to EAPI=7
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
index 9d17529ffecb..b618e667ca77 100644
--- a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
+++ b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit flag-o-matic eutils
+inherit flag-o-matic
DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
HOMEPAGE="http://jfs.sourceforge.net/"
@@ -16,10 +16,10 @@ IUSE="static"
DOCS=( AUTHORS ChangeLog NEWS README )
-src_prepare() {
- epatch "${FILESDIR}"/${P}-linux-headers.patch #448844
- epatch "${FILESDIR}"/${P}-sysmacros.patch #580056
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-linux-headers.patch #448844
+ "${FILESDIR}"/${P}-sysmacros.patch #580056
+)
src_configure() {
# It doesn't compile on alpha without this LDFLAGS
@@ -33,6 +33,6 @@ src_install() {
default
rm -f "${ED}"/sbin/{mkfs,fsck}.jfs || die
- dosym /sbin/jfs_mkfs /sbin/mkfs.jfs
- dosym /sbin/jfs_fsck /sbin/fsck.jfs
+ dosym jfs_mkfs /sbin/mkfs.jfs
+ dosym jfs_fsck /sbin/fsck.jfs
}