summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-30 20:30:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-02 20:08:03 +0200
commit38c4e6130d616269ba70a8f1bef4e38fda68da3f (patch)
tree86387c9679c69ddf0917c6ba10b19cf3cfdf20f2
parentapp-text/unpaper: drop 6.1-r1 (diff)
downloadgentoo-38c4e613.tar.gz
gentoo-38c4e613.tar.bz2
gentoo-38c4e613.zip
sys-apps/dtc: drop 1.5.0, 1.5.0-r2, EAPI-6--
Closes: https://bugs.gentoo.org/743977 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sys-apps/dtc/Manifest1
-rw-r--r--sys-apps/dtc/dtc-1.5.0-r2.ebuild87
-rw-r--r--sys-apps/dtc/dtc-1.5.0.ebuild59
-rw-r--r--sys-apps/dtc/files/dtc-1.4.4-posix-shell.patch48
-rw-r--r--sys-apps/dtc/files/dtc-1.5.0-fdt_check_full-visibility.patch12
-rw-r--r--sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch50
6 files changed, 0 insertions, 257 deletions
diff --git a/sys-apps/dtc/Manifest b/sys-apps/dtc/Manifest
index ce7f0fee1d6b..993154b8a266 100644
--- a/sys-apps/dtc/Manifest
+++ b/sys-apps/dtc/Manifest
@@ -1,2 +1 @@
-DIST dtc-1.5.0.tar.xz 152936 BLAKE2B 4ad9cf8f8fd0ccde0c7b8b66c0039eb9b012ed26e51387c06c03fa7950ca194878bbb23b50be5b80c4d4e18140d6316092a9f0eea87e5d713856635dcfc1b0ec SHA512 fd1e692a1b7bf7987f921ad17d9be6719f7b3aa7915873b45fa86f4ecb1398a0a62cdf53c1fddf98a0f7fed9bf34a79f684018bd01a2b5e88746b50879bf7102
DIST dtc-1.6.0.tar.xz 158584 BLAKE2B 47b15b5df7f5d87369d6daaad87f2989a80865f2fab19f89d050d390a9f8319bcd86a36e12f7cc8d62947bb4d1335769071d0e3ea0a6e16861aea163e78f4696 SHA512 15433b24f1d6b7ed1f8066d050bd1bcbf988731aa38147564e3dd04b5f69af8d69e03befdc621a768526c620425a9bdd24aad4f9ff135930d6a1eeb0625f7de3
diff --git a/sys-apps/dtc/dtc-1.5.0-r2.ebuild b/sys-apps/dtc/dtc-1.5.0-r2.ebuild
deleted file mode 100644
index 3394d77c0623..000000000000
--- a/sys-apps/dtc/dtc-1.5.0-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit multilib toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
- inherit git-r3
-else
- SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-DESCRIPTION="Open Firmware device tree compiler"
-HOMEPAGE="https://devicetree.org/ https://git.kernel.org/cgit/utils/dtc/dtc.git/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="static-libs yaml"
-
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-RDEPEND="yaml? ( dev-libs/libyaml )"
-DEPEND="${RDEPEND}"
-
-DOCS="
- Documentation/dt-object-internal.txt
- Documentation/dts-format.txt
- Documentation/manual.txt
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
- "${FILESDIR}"/${PN}-1.5.0-fdt_check_full-visibility.patch
- "${FILESDIR}"/${PN}-1.5.0-gcc-10.patch
-)
-
-_emake() {
- # valgrind is used only in 'make checkm'
- emake \
- NO_PYTHON=1 \
- NO_VALGRIND=1 \
- NO_YAML=$(usex !yaml 1 0) \
- \
- AR="$(tc-getAR)" \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- \
- V=1 \
- \
- PREFIX="${EPREFIX}/usr" \
- \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- \
- "$@"
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e '/^CFLAGS =/s:=:+=:' \
- -e '/^CPPFLAGS =/s:=:+=:' \
- -e 's:-Werror::' \
- -e 's:-g -Os::' \
- Makefile || die
-
- tc-export AR CC PKG_CONFIG
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake check
-}
-
-src_install() {
- _emake DESTDIR="${D}" install
-
- use static-libs || find "${ED}" -name '*.a' -delete
-}
diff --git a/sys-apps/dtc/dtc-1.5.0.ebuild b/sys-apps/dtc/dtc-1.5.0.ebuild
deleted file mode 100644
index 1a41da72cf8f..000000000000
--- a/sys-apps/dtc/dtc-1.5.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit multilib toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
- inherit git-r3
-else
- SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-fi
-
-DESCRIPTION="Open Firmware device tree compiler"
-HOMEPAGE="https://devicetree.org/ https://git.kernel.org/cgit/utils/dtc/dtc.git/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="static-libs"
-
-DEPEND="
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-DOCS="
- Documentation/dt-object-internal.txt
- Documentation/dts-format.txt
- Documentation/manual.txt
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
- "${FILESDIR}"/${PN}-1.5.0-fdt_check_full-visibility.patch
- "${FILESDIR}"/${PN}-1.5.0-gcc-10.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e '/^CFLAGS =/s:=:+=:' \
- -e '/^CPPFLAGS =/s:=:+=:' \
- -e 's:-Werror::' \
- -e 's:-g -Os::' \
- -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
- -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
- Makefile || die
-
- tc-export AR CC PKG_CONFIG
- export V=1
-}
-
-src_install() {
- default
-
- use static-libs || find "${ED}" -name '*.a' -delete
-}
diff --git a/sys-apps/dtc/files/dtc-1.4.4-posix-shell.patch b/sys-apps/dtc/files/dtc-1.4.4-posix-shell.patch
deleted file mode 100644
index b9b0175c0bd3..000000000000
--- a/sys-apps/dtc/files/dtc-1.4.4-posix-shell.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 4d9522764985462741c7bb4af1ab231b9251476b Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@chromium.org>
-Date: Wed, 10 Jan 2018 00:41:43 -0500
-Subject: [PATCH] dtdiff: change to POSIX shell
-
-This changes from the bash-specific process substitution feature to
-reading with pipes. It relies on /dev/fd or /proc/self/fd existing.
-
-URL: https://crbug.com/756559
-Signed-off-by: Mike Frysinger <vapier@chromium.org>
----
- dtdiff | 19 +++++++++++++------
- 1 file changed, 13 insertions(+), 6 deletions(-)
-
-diff --git a/dtdiff b/dtdiff
-index 5fa772b0ab62..4d1b71756c2f 100644
---- a/dtdiff
-+++ b/dtdiff
-@@ -1,8 +1,4 @@
--#! /bin/bash
--
--# This script uses the bash <(...) extension.
--# If you want to change this to work with a generic /bin/sh, make sure
--# you fix that.
-+#! /bin/sh
-
-
- DTC=dtc
-@@ -35,4 +31,15 @@ if [ $# != 2 ]; then
- exit 1
- fi
-
--diff -u <(source_and_sort "$1") <(source_and_sort "$2")
-+for dir in /dev/fd /proc/self/fd; do
-+ if [ -d "${dir}" ]; then
-+ break
-+ fi
-+done
-+
-+source_and_sort "$1" | (
-+ # Duplicate current stdin from the first file to fd 3 so we can change fd 0
-+ # to the second file.
-+ exec 3<&0
-+ source_and_sort "$2" | diff -u "${dir}/3" "${dir}/0"
-+)
---
-2.15.1
-
diff --git a/sys-apps/dtc/files/dtc-1.5.0-fdt_check_full-visibility.patch b/sys-apps/dtc/files/dtc-1.5.0-fdt_check_full-visibility.patch
deleted file mode 100644
index a5a3d7524c45..000000000000
--- a/sys-apps/dtc/files/dtc-1.5.0-fdt_check_full-visibility.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/libfdt/version.lds b/libfdt/version.lds
-index 9f5d708..6b0f6d8 100644
---- a/libfdt/version.lds
-+++ b/libfdt/version.lds
-@@ -1,6 +1,7 @@
- LIBFDT_1.2 {
- global:
- fdt_next_node;
-+ fdt_check_full;
- fdt_check_header;
- fdt_move;
- fdt_string;
diff --git a/sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch b/sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch
deleted file mode 100644
index 80773bfaebbc..000000000000
--- a/sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-https://bugs.gentoo.org/706660
-https://git.kernel.org/pub/scm/utils/dtc/dtc.git/patch/?id=0e9225eb0dfec51def612b928d2f1836b092bc7e
-
-From 0e9225eb0dfec51def612b928d2f1836b092bc7e Mon Sep 17 00:00:00 2001
-From: Dirk Mueller <dmueller@suse.com>
-Date: Tue, 14 Jan 2020 18:53:41 +0100
-Subject: Remove redundant YYLOC global declaration
-
-gcc 10 will default to -fno-common, which causes this error at link
-time:
-
- (.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
-
-This is because both dtc-lexer as well as dtc-parser define the same
-global symbol yyloc. Before with -fcommon those were merged into one
-defintion. The proper solution would be to to mark this as "extern",
-however that leads to:
-
- dtc-lexer.l:26:16: error: redundant redeclaration of 'yylloc' [-Werror=redundant-decls]
- 26 | extern YYLTYPE yylloc;
- | ^~~~~~
-In file included from dtc-lexer.l:24:
-dtc-parser.tab.h:127:16: note: previous declaration of 'yylloc' was here
- 127 | extern YYLTYPE yylloc;
- | ^~~~~~
-cc1: all warnings being treated as errors
-
-which means the declaration is completely redundant and can just be
-dropped.
-
-Signed-off-by: Dirk Mueller <dmueller@suse.com>
-Message-Id: <20200114175341.2994-1-dmueller@suse.com>
-Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
----
- dtc-lexer.l | 1 -
- 1 file changed, 1 deletion(-)
-
---- a/dtc-lexer.l
-+++ b/dtc-lexer.l
-@@ -23,7 +23,6 @@ LINECOMMENT "//".*\n
- #include "srcpos.h"
- #include "dtc-parser.tab.h"
-
--YYLTYPE yylloc;
- extern bool treesource_error;
-
- /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
---
-cgit 1.2-0.3.lf.el7
-