summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-01-22 12:22:31 -0500
committerBrian Evans <grknight@gentoo.org>2019-01-22 12:22:31 -0500
commit38d1c0af45cb88e995c75f3c7695e5f5cdbc73e1 (patch)
tree3b5da165f6b85886fc9f2b940e0521a5e3833a8d
parentx11-libs/libdrm: Version bump to 2.4.97 (diff)
downloadgentoo-38d1c0af.tar.gz
gentoo-38d1c0af.tar.bz2
gentoo-38d1c0af.zip
dev-db/mycli: Version bump for 1.19.0; Update 9999 requirements
Package-Manager: Portage-2.3.57, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-db/mycli/Manifest1
-rw-r--r--dev-db/mycli/metadata.xml3
-rw-r--r--dev-db/mycli/mycli-1.19.0.ebuild41
-rw-r--r--dev-db/mycli/mycli-9999.ebuild10
4 files changed, 50 insertions, 5 deletions
diff --git a/dev-db/mycli/Manifest b/dev-db/mycli/Manifest
index a7fc45d20322..61090c13fb0b 100644
--- a/dev-db/mycli/Manifest
+++ b/dev-db/mycli/Manifest
@@ -1,2 +1,3 @@
DIST mycli-1.15.0.tar.gz 275065 BLAKE2B 47ae049a7a669d18fc2bb467dd4ee6d1bbe23a86115db6d1965c48c93a2a1be9bb8b4427b377f8ce935b957c854c1c4bf4a87fdea07f27329a13fd6a28b59559 SHA512 7a7d98220c4a679340dbf3c3c9fb3eaab7698f7abbe3e62835a03df10b59c79f0dfd916e9f7b39f12215063849ecadf9d08d086d14b00666b67bac1d092609f2
DIST mycli-1.17.0.tar.gz 276786 BLAKE2B 203c54b58a7876fd0bab5a05880621263e5cdf786b13207f04dfaf38866f5a7250e8fe8e1c5870aa9d3f562cf9963f15cc433e3ddd2232531f4c823e46778ac7 SHA512 bd64f44ed7b16a1e9c684da52fa60436876b26333e2705e5226c4fab3a979c6680314447333d01e4fdb274d33a7f093cbb2f732e5b4e04c5330066f9918a35ba
+DIST mycli-1.19.0.tar.gz 263255 BLAKE2B 524190429476793af038c8302f43389884a6ee24a05b0b8c739f290dbfdebec3336bd14567eafff2ea3351430791e4844e16dfc5affb1b28bb57d3759b496350 SHA512 8c6003a09a888c2ac6f35a881ca072ba8972f66b13319cbff73f7a525d1f808b767dcef0121b6272a1b82eed1a02c8c417d5805e5a8ce0c141545f28ff3c3a33
diff --git a/dev-db/mycli/metadata.xml b/dev-db/mycli/metadata.xml
index c80f94490085..a5372d6a312e 100644
--- a/dev-db/mycli/metadata.xml
+++ b/dev-db/mycli/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="github">dbcli/mycli</remote-id>
</upstream>
+ <use>
+ <flag name="ssh">Add support for connection over SSH tunnel</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-db/mycli/mycli-1.19.0.ebuild b/dev-db/mycli/mycli-1.19.0.ebuild
new file mode 100644
index 000000000000..957f70361a50
--- /dev/null
+++ b/dev-db/mycli/mycli-1.19.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
+
+HOMEPAGE="https://www.mycli.net"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssh test"
+RDEPEND="
+ >=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}]
+ <dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
+ ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] ${RDEPEND} )"
+
+python_test() {
+ pytest --capture=sys \
+ --showlocals \
+ --doctest-modules \
+ --doctest-ignore-import-errors \
+ --ignore=setup.py \
+ --ignore=mycli/magic.py \
+ --ignore=mycli/packages/parseutils.py \
+ --ignore=test/features
+}
diff --git a/dev-db/mycli/mycli-9999.ebuild b/dev-db/mycli/mycli-9999.ebuild
index 70338c41f800..a1f322dc698e 100644
--- a/dev-db/mycli/mycli-9999.ebuild
+++ b/dev-db/mycli/mycli-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,18 +14,18 @@ SRC_URI=""
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="ssh test"
RDEPEND="
>=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
>=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/prompt_toolkit-2.0.0[${PYTHON_USEDEP}]
- <dev-python/prompt_toolkit-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
>=dev-python/pygments-2.0[${PYTHON_USEDEP}]
>=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
>=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}]
<dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
+ ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )
"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] ${RDEPEND} )"