summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-02-21 17:39:37 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-02-21 17:39:37 +0700
commit38d48c078357aa73e4474ac1b06b59347a6c0f58 (patch)
tree42f4e384edae919c72e0dc1eb54814269d129015
parentsci-geosciences/routino: PEP517 ebuild (diff)
downloadgentoo-38d48c078357aa73e4474ac1b06b59347a6c0f58.tar.gz
gentoo-38d48c078357aa73e4474ac1b06b59347a6c0f58.tar.bz2
gentoo-38d48c078357aa73e4474ac1b06b59347a6c0f58.zip
sci-geosciences/routino: rm old revision
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--sci-geosciences/routino/routino-3.3.3-r3.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/sci-geosciences/routino/routino-3.3.3-r3.ebuild b/sci-geosciences/routino/routino-3.3.3-r3.ebuild
deleted file mode 100644
index bc39cf589cc9..000000000000
--- a/sci-geosciences/routino/routino-3.3.3-r3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..11} )
-inherit toolchain-funcs distutils-r1
-
-DESCRIPTION="Routing application based on openstreetmap data"
-HOMEPAGE="https://routino.org/"
-SRC_URI="https://routino.org/download/${P}.tgz"
-
-LICENSE="AGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python test"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-lang/swig[pcre]
- )
-"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-
-PATCHES=( "${FILESDIR}"/${PN}-3.3.2.patch )
-
-src_prepare() {
- default
-
- sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
- -e "s@CC=gcc@CC=$(tc-getCC)@" \
- -e "s@LD=gcc@LD=$(tc-getCC)@" \
- Makefile.conf || die "failed sed"
-}
-
-src_compile() {
- emake -j1
-
- rm README.txt || die "rm README.txt failed"
- mv doc/README.txt . || die "mv doc/README.txt . failed"
-
- if use python; then
- pushd python > /dev/null || die
- distutils-r1_src_compile
- popd > /dev/null || die
- fi
-}
-
-python_compile() {
- rm -f build/.timestamp || die
- emake PYTHON=${EPYTHON}
-}
-
-src_test() {
- emake test
-
- # Need to fix import issues with these
- #if use python; then
- # pushd python > /dev/null || die
- # distutils-r1_src_test
- # popd > /dev/null || die
- #fi
-}
-
-python_test() {
- emake PYTHON=${EPYTHON} test
-}
-
-src_install() {
- default
-
- if use python; then
- pushd python > /dev/null || die
- distutils-r1_src_install
- newdoc README.txt README_python.txt
- popd > /dev/null || die
- fi
-}
-
-python_install() {
- esetup.py install
- python_optimize
-}