summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-27 21:11:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-27 21:25:25 +0300
commit38e2cd2bd6567e0e8be5d3d32af44b35cee340a8 (patch)
treec02ff30e6feef919c60f54b24e5b11a27ec4f208
parentdev-python/fitsio: enable py3.11 (diff)
downloadgentoo-38e2cd2b.tar.gz
gentoo-38e2cd2b.tar.bz2
gentoo-38e2cd2b.zip
dev-python/mdit-py-plugins: add 0.3.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/mdit-py-plugins/Manifest1
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index c04b4ab0815a..a7ab311aa1fa 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1 +1,2 @@
DIST mdit-py-plugins-0.3.0.gh.tar.gz 50654 BLAKE2B e84842e7cada1d9239f1d449c1a21ed654ab13017ea92f82190053b37371bc7e06d7afb65f6f56f7fa935666d24d05dca99628121bd4092a1143c289588ddfa4 SHA512 dd6aa738c6d93e45437326b1be52e0a9fc411aa3beacb61690919c272979c97ac1b38116b1ebb01c7d8fe724d4af9621c81ccd45131a690df8a2c0c325eef0e8
+DIST mdit-py-plugins-0.3.1.gh.tar.gz 53897 BLAKE2B 57bb08ec6f90d28beb10fbd57d980b1d6f7b1df5d5c3d537685ec1c34d2ea74ea9e5facd0ee432d12924ae2d35d32e3c4dc3600485486b6cd49d5568bffbf48f SHA512 a934953e95eba04f5c1626d8256fed53cbbb26e35d816b41b7aaf968b452e3bfaa99e3008009dbdd8d9e7c89497916916c2cc1fabbecb735624231cafee864ea
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild
new file mode 100644
index 000000000000..049b7b757192
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest