summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-09 13:06:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-09 13:07:45 -0500
commit38fa141928a9d2027d55c6cd8fe5a4205a22f6d6 (patch)
tree4d4edd241e18c33b716900a05cb38d40df2f3351
parentsys-apps/openrc: 0.44.3 bump (diff)
downloadgentoo-38fa141928a9d2027d55c6cd8fe5a4205a22f6d6.tar.gz
gentoo-38fa141928a9d2027d55c6cd8fe5a4205a22f6d6.tar.bz2
gentoo-38fa141928a9d2027d55c6cd8fe5a4205a22f6d6.zip
sys-apps/openrc: remove old
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/openrc/Manifest1
-rw-r--r--sys-apps/openrc/openrc-0.44.1.ebuild164
2 files changed, 0 insertions, 165 deletions
diff --git a/sys-apps/openrc/Manifest b/sys-apps/openrc/Manifest
index 4504762e2b65..7e122a8f1de7 100644
--- a/sys-apps/openrc/Manifest
+++ b/sys-apps/openrc/Manifest
@@ -1,3 +1,2 @@
DIST openrc-0.43.5.tar.gz 242146 BLAKE2B 993d3895588e8f1383049006834f944faaae0f889d3afcae5bff697db9f26383712f18aba52ce07d835f1d2bbe8ef19ef116ad60141d1eb0650767430d1d9967 SHA512 680c1549a8a37eb3a719f3e026888d045d26c98357d6e6eaf09069a23a001272deaca8cac4a9b8fd79f489c4cfb4fe2c7b5d481d1469798a8f5ec470d0cadbe3
-DIST openrc-0.44.1.tar.gz 251662 BLAKE2B 53af6372289dfa80de98ba0685699d22f0fddcbd55b972a5878f519411e867ab31193a37ddfe3f26e68cf14a54171f8b074f466c3da3e4a6a6dd899980a1717f SHA512 6514f997b18fb320289ddf41f417cea5192fd25c81f32fa5a44ef867d0cd649d3d242621d247bda61da3dfa60f5fde312310bd405241bcdbd420ded69c6f875d
DIST openrc-0.44.3.tar.gz 252469 BLAKE2B 6e1a952c4459ace4d67b5c07a44618324c1fd226d55b083e9701999559e2726d49654bf00a7f45f867f96b7550d782bf565cd687b3ac964d61217ed221445041 SHA512 b066feb89d3b58383d5dc20e731f016f0ecdaa72b95af750e49ba31d80d88b83f3df4d9a7d57c8b106c29cc5b0a004b9eee78192cf776b4cfacdcdcb1d7beeb8
diff --git a/sys-apps/openrc/openrc-0.44.1.ebuild b/sys-apps/openrc/openrc-0.44.1.ebuild
deleted file mode 100644
index c53c141b2d97..000000000000
--- a/sys-apps/openrc/openrc-0.44.1.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic meson pam toolchain-funcs
-
-DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
-HOMEPAGE="https://github.com/openrc/openrc/"
-
-if [[ ${PV} =~ ^9{4,}$ ]]; then
- EGIT_REPO_URI="https://github.com/OpenRC/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/OpenRC/openrc/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="audit bash debug ncurses pam newnet +netifrc selinux sysv-utils unicode"
-
-COMMON_DEPEND="
- ncurses? ( sys-libs/ncurses:0= )
- pam? ( sys-libs/pam )
- audit? ( sys-process/audit )
- sys-process/psmisc
- !<sys-process/procps-3.3.9-r2
- selinux? (
- sys-apps/policycoreutils
- >=sys-libs/libselinux-2.6
- )
- !<sys-apps/baselayout-2.1-r1
- !<sys-fs/udev-init-scripts-27"
-DEPEND="${COMMON_DEPEND}
- virtual/os-headers
- ncurses? ( virtual/pkgconfig )"
-RDEPEND="${COMMON_DEPEND}
- bash? ( app-shells/bash )
- !prefix? (
- sysv-utils? (
- !sys-apps/systemd[sysv-utils(-)]
- !sys-apps/sysvinit
- )
- !sysv-utils? ( >=sys-apps/sysvinit-2.86-r6[selinux?] )
- virtual/tmpfiles
- )
- selinux? (
- >=sec-policy/selinux-base-policy-2.20170204-r4
- >=sec-policy/selinux-openrc-2.20170204-r4
- )
- !<app-shells/gentoo-bashcomp-20180302
- !<app-shells/gentoo-zsh-completions-20180228
-"
-
-PDEPEND="netifrc? ( net-misc/netifrc )"
-
-src_configure() {
- local emesonargs=(
- $(meson_feature audit)
- "-Dbranding=\"Gentoo Linux\""
- $(meson_use newnet)
- -Dos=Linux
- $(meson_use pam)
- $(meson_feature selinux)
- -Dshell=$(usex bash /bin/bash /bin/sh)
- $(meson_use sysv-utils sysvinit)
- -Dtermcap=$(usev ncurses)
- )
- # export DEBUG=$(usev debug)
- meson_src_configure
-}
-
-# set_config <file> <option name> <yes value> <no value> test
-# a value of "#" will just comment out the option
-set_config() {
- local file="${ED}/$1" var=$2 val com
- eval "${@:5}" && val=$3 || val=$4
- [[ ${val} == "#" ]] && com="#" && val='\2'
- sed -i -r -e "/^#?${var}=/{s:=([\"'])?([^ ]*)\1?:=\1${val}\1:;s:^#?:${com}:}" "${file}"
-}
-
-set_config_yes_no() {
- set_config "$1" "$2" YES NO "${@:3}"
-}
-
-src_install() {
- meson_install
-
- keepdir /lib/rc/tmp
-
- # Setup unicode defaults for silly unicode users
- set_config_yes_no /etc/rc.conf unicode use unicode
-
- # Cater to the norm
- set_config_yes_no /etc/conf.d/keymaps windowkeys '(' use x86 '||' use amd64 ')'
-
- # On HPPA, do not run consolefont by default (bug #222889)
- if use hppa; then
- rm -f "${ED}"/etc/runlevels/boot/consolefont
- fi
-
- # Support for logfile rotation
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/openrc.logrotate openrc
-
- if use pam; then
- # install gentoo pam.d files
- newpamd "${FILESDIR}"/start-stop-daemon.pam start-stop-daemon
- newpamd "${FILESDIR}"/start-stop-daemon.pam supervise-daemon
- fi
-
- # install documentation
- dodoc ChangeLog *.md
-}
-
-pkg_preinst() {
- # avoid default thrashing in conf.d files when possible #295406
- if [[ -e "${EROOT}"/etc/conf.d/hostname ]] ; then
- (
- unset hostname HOSTNAME
- source "${EROOT}"/etc/conf.d/hostname
- : ${hostname:=${HOSTNAME}}
- [[ -n ${hostname} ]] && set_config /etc/conf.d/hostname hostname "${hostname}"
- )
- fi
-
- # set default interactive shell to sulogin if it exists
- set_config /etc/rc.conf rc_shell /sbin/sulogin "#" test -e /sbin/sulogin
- return 0
-}
-
-pkg_postinst() {
- if use hppa; then
- elog "Setting the console font does not work on all HPPA consoles."
- elog "You can still enable it by running:"
- elog "# rc-update add consolefont boot"
- fi
-
- # Added for 0.35.
- if [[ ! -h "${EROOT}"/lib ]]; then
- if [[ -d "${EROOT}/$(get_libdir)"/rc ]]; then
- cp -RPp "${EROOT}/$(get_libdir)/rc" "${EROOT}"/lib
- fi
- fi
-
- if ! use newnet && ! use netifrc; then
- ewarn "You have emerged OpenRc without network support. This"
- ewarn "means you need to SET UP a network manager such as"
- ewarn " net-misc/netifrc, net-misc/dhcpcd, net-misc/connman,"
- ewarn " net-misc/NetworkManager, or net-vpn/badvpn."
- ewarn "Or, you have the option of emerging openrc with the newnet"
- ewarn "use flag and configuring /etc/conf.d/network and"
- ewarn "/etc/conf.d/staticroute if you only use static interfaces."
- ewarn
- fi
-
- if use newnet && [ ! -e "${EROOT}"/etc/runlevels/boot/network ]; then
- ewarn "Please add the network service to your boot runlevel"
- ewarn "as soon as possible. Not doing so could leave you with a system"
- ewarn "without networking."
- ewarn
- fi
-}