summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-12 16:29:45 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-13 07:22:42 +0200
commit38fd66a0845ef5cd4a41ff4072d3eb9102fae712 (patch)
tree2120fe1c5b171946308aece8e87f5c7c6521f8e9
parentdev-ruby/sourcemap: fix minitest deprecation (diff)
downloadgentoo-38fd66a0845ef5cd4a41ff4072d3eb9102fae712.tar.gz
gentoo-38fd66a0845ef5cd4a41ff4072d3eb9102fae712.tar.bz2
gentoo-38fd66a0845ef5cd4a41ff4072d3eb9102fae712.zip
dev-ruby/snaky_hash: use correct test dependency
Closes: https://bugs.gentoo.org/912030 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild b/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild
index 1b616e43d223..26b1db17da94 100644
--- a/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild
+++ b/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -26,7 +26,7 @@ ruby_add_rdepend "
>=dev-ruby/version_gem-1.1.1:1
"
-ruby_add_depend "test? ( >=dev-ruby/rspec-pending_for-0.1:0 )"
+ruby_add_depend "test? ( dev-ruby/rspec-block_is_expected )"
all_ruby_prepare() {
sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die