summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-26 12:30:34 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-26 12:30:34 +0100
commit38fe117e4a812fe142f2e8f491f17f0c93f2379b (patch)
treef0f6964d59fbd4d77d985041ab23bf2e613576cd
parentsci-libs/alglib: Bump to 3.17.0 (diff)
downloadgentoo-38fe117e4a812fe142f2e8f491f17f0c93f2379b.tar.gz
gentoo-38fe117e4a812fe142f2e8f491f17f0c93f2379b.tar.bz2
gentoo-38fe117e4a812fe142f2e8f491f17f0c93f2379b.zip
sci-libs/cmpfit: Bump to 1.4
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/cmpfit/Manifest1
-rw-r--r--sci-libs/cmpfit/cmpfit-1.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/cmpfit/Manifest b/sci-libs/cmpfit/Manifest
index a25335adfb19..27fdd2f18532 100644
--- a/sci-libs/cmpfit/Manifest
+++ b/sci-libs/cmpfit/Manifest
@@ -1 +1,2 @@
DIST cmpfit-1.2.tar.gz 30431 BLAKE2B 3613fc307b0f1cd792ea9b1436109da77960dcb1985920de2c97e3b8f22d49d68358c0077dd3af5c6d2ea6e7b172d715643221b8df8f84a704688fda2f1ef51a SHA512 232a39538396f166efd9c7a9fc687e0ac8fd3090f871f54fb0c131a1ed02cc05a60904894d853d8eb76d88e70a1fbab4bce3ad0b5990408c77d5a6028a3b466c
+DIST cmpfit-1.4.tar.gz 30659 BLAKE2B f076f69e83d1eb78eda2894cded85f920cef1c95bcb60b042e98d33919e12cac62ffe4ad76ddc9ca0ef17f887289dc37b0bde969e4e04470b491b03b841bbeea SHA512 0a0c869bcf202a0dbc9fd6b6939a6382cc8701f09ca9aada90dde809135c2a8436709a84a8be53696e8d09f49f1d14f80c9d4c8c1c6cd418260939fc0ec5dced
diff --git a/sci-libs/cmpfit/cmpfit-1.4.ebuild b/sci-libs/cmpfit/cmpfit-1.4.ebuild
new file mode 100644
index 000000000000..ff93f77a140c
--- /dev/null
+++ b/sci-libs/cmpfit/cmpfit-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MINPACK-1 Least Squares Fitting Library in C"
+HOMEPAGE="http://www.physics.wisc.edu/~craigm/idl/cmpfit.html"
+SRC_URI="http://www.physics.wisc.edu/~craigm/idl/down/${P}.tar.gz"
+
+LICENSE="public-domain minpack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README DISCLAIMER )
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} -fPIC -c mpfit.c -o mpfit.so || die "PIC compilation failed"
+ $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname=libmpfit.so mpfit.so -lm -o libmpfit.so || die "linking failed"
+}
+
+src_test() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} testmpfit.c -L. -lmpfit -lm -o testmpfit || die
+ LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH} ./testmpfit || die
+}
+
+src_install() {
+ dolib.so libmpfit.so
+ doheader mpfit.h
+ einstalldocs
+}