summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-17 08:52:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-17 09:28:45 +0200
commit38ff18ce0e2c2a22948de5df737af447b0aed916 (patch)
treef0c374c889f551ec3d02a58a295d47f0e752b9b8
parentdev-python/zeroconf: Bump to 0.36.0 (diff)
downloadgentoo-38ff18ce0e2c2a22948de5df737af447b0aed916.tar.gz
gentoo-38ff18ce0e2c2a22948de5df737af447b0aed916.tar.bz2
gentoo-38ff18ce0e2c2a22948de5df737af447b0aed916.zip
dev-python/httpretty: Bump to 1.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-1.1.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index 690c3747b93e..b985df8da2d4 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1 +1,2 @@
DIST httpretty-1.1.3.tar.gz 441309 BLAKE2B 9c8138bd83fd93602d4ab72e9ee2ff27605a851ee4e7e61f5fbe0d1423041479311315cf0168acb2474c2b579401c6817f4713f61707e21faad076968b2aa1f5 SHA512 3bac68ecb78efc7592f9ab314ca9ef570c8193fb7c2ab3d3fa003b0ff623ac57d6a74f8f0e7b6c2ed45f30e520d157345db56837212d9acd4ec6259570a43dfe
+DIST httpretty-1.1.4.tar.gz 442389 BLAKE2B 020a9fd2b5dc9790b53009caac37a3cf5a0e47102b9be05f4df255880f5daf5e7689714e0c0a8f223155d191c471cb5ff4f9b0d0d34b07bd5f377311ed56ba25 SHA512 4daceea4f30ce181e871167d304bd7af9d504364f55d42f8025770f2efe7e833d018aed681c8733d653d4de90db3433e999c56bccd4675f81e66d1cc4023e418
diff --git a/dev-python/httpretty/httpretty-1.1.4.ebuild b/dev-python/httpretty/httpretty-1.1.4.ebuild
new file mode 100644
index 000000000000..3d137d5066a1
--- /dev/null
+++ b/dev-python/httpretty/httpretty-1.1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+# redis skipped as it requires a redis server running
+DEPEND="
+ test? (
+ >=dev-python/boto3-1.17.72[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.18.1[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # remove useless deps
+ sed -i -e '/rednose/d' setup.cfg || die
+ # tests requiring network access
+ rm tests/functional/test_passthrough.py || die
+
+ distutils-r1_python_prepare_all
+}