summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-12-30 17:57:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-30 17:59:15 +0000
commit390435ad20e62c5fa0fc8a3b9a09f0f0ddcdf58c (patch)
treea59f0759508f0b14838e69f1aef20ccc75b9b3f3
parentnet-analyzer/icinga: 1.14.2 stable amd64 and x86 for bug 638186 (diff)
downloadgentoo-390435ad.tar.gz
gentoo-390435ad.tar.bz2
gentoo-390435ad.zip
sys-devel/crossdev: bump up to 20171230
A few user-facing changes: - CROSSCOMPILE_OPTS=headers-only -> USE=headers-only transition (bug #642712) - USE=sanitize and USE=vtv are enabled only for whitelisted targets (bug #618786) Closes: https://bugs.gentoo.org/618786 Bug: https://bugs.gentoo.org/642712 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20171230.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index bef22882bf31..f447327f0cc2 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -2,3 +2,4 @@ DIST crossdev-20151026.tar.xz 22160 BLAKE2B 36cd292ffc9e8051d2684315a1546260ea3d
DIST crossdev-20160602.tar.xz 22292 BLAKE2B f3ade0af8ce39b6c9a5aed30845e5633b68da0796cd43c9ae05450f8a982027e428fbcca110b485a41c335963ff932c1b5cfcca3aba6143f648bc8f4ed2e27b7 SHA512 580cc51e599086a14c51153e656d30b5c2f0e08c7601384d3e082716edeaa532e832b515df2517618cc51be187fcf8738db10e412a5635a16d0bb58b1631a53e
DIST crossdev-20171119.tar.xz 22596 BLAKE2B 4e606f63aad234684b6400203fc22a9ff7dbd9f14dca5e2f2055f08207e412a3a3352921109100b32b4f6fb51cc0836ada4e8db8011d781e9e7c990d6c92d3d1 SHA512 3b8d7b89adf06d5ffef169ed1015532220c997731e083fd73c27d80ea09a6a7efd456734104aa58ef386426f9a04fed3147f37aefe4106c378a0b865bfffb2f0
DIST crossdev-20171227.tar.xz 22780 BLAKE2B 983dd5da66c1e467b622867c9d474c7e1b7befd4fb91e1e008f7d7d8416bb077bcd06274fe8145ec9338f652e780d2ddd3a501f79b46af280cb5dbb4c8324965 SHA512 bc91e95aa9a927416f2b97b989657de5a740707bb4f4cbfc3d9e0626c3977b3091040104a52205762ef9cc0d3cd7933fb527efa20086dedfd9b390dc2be167a0
+DIST crossdev-20171230.tar.xz 23016 BLAKE2B 4661b3f9fac314b7346f0de7227d12ae2d6851e448f6d065471499df8ada5d699ef91c6b6bca285b2aefcbf67ab351fefbe9344c0884a7c0d33ff27215c8ed9c SHA512 bf8761a3018790501adb4bb173e3281d1d7628de8f65a1aa5df0b328a4af8088be466dbe8c185e7ed44aca31b078320a4f62c56351f4b7cbf832349184d9709f
diff --git a/sys-devel/crossdev/crossdev-20171230.ebuild b/sys-devel/crossdev/crossdev-20171230.ebuild
new file mode 100644
index 000000000000..73d9c4690063
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20171230.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}