summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-08 14:59:51 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-08 18:22:35 +0200
commit391bca5650c7e959f6bf0b349e5aa5a3b573ed1c (patch)
treea4cd9381aaa5605ca6c84a03acbc6e7d68a7943a
parentgames-simulation/openrct2: add 0.4.6, update 9999 (diff)
downloadgentoo-391bca5650c7e959f6bf0b349e5aa5a3b573ed1c.tar.gz
gentoo-391bca5650c7e959f6bf0b349e5aa5a3b573ed1c.tar.bz2
gentoo-391bca5650c7e959f6bf0b349e5aa5a3b573ed1c.zip
games-misc/lolcat: allow newer optimist versions to work
Closes: https://bugs.gentoo.org/911512 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--games-misc/lolcat/lolcat-100.0.1-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-misc/lolcat/lolcat-100.0.1-r3.ebuild b/games-misc/lolcat/lolcat-100.0.1-r3.ebuild
new file mode 100644
index 000000000000..dd460e83932a
--- /dev/null
+++ b/games-misc/lolcat/lolcat-100.0.1-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="lolcat.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rainbows and unicorns!"
+HOMEPAGE="https://github.com/busyloop/lolcat"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/optimist:3
+ >=dev-ruby/paint-2.1:0"
+
+all_ruby_prepare() {
+ sed -e '/manpages/ s:^:#:' \
+ -e 's/git ls-files --/echo/' \
+ -e 's/git ls-files/find/' \
+ -e '/optimist/ s/3.0.0/3.0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ doman man/lolcat.6
+ ruby_fakegem_binwrapper lolcat
+}