summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-08 13:11:47 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-28 23:00:20 -0400
commit391c7f55642b99cd89c4367207f2c3990f17a2f6 (patch)
treee12e01469619852232ce7d01a6201134ac898e3d
parentdev-db/opendbx: workaround build failure with GCC 11 in 1.4.6-r3 (diff)
downloadgentoo-391c7f55.tar.gz
gentoo-391c7f55.tar.bz2
gentoo-391c7f55.zip
media-libs/glfw: rename wayland useflag to wayland-only
Closes: https://bugs.gentoo.org/616968 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21566 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-libs/glfw/glfw-3.3.4-r1.ebuild14
-rw-r--r--media-libs/glfw/metadata.xml3
2 files changed, 10 insertions, 7 deletions
diff --git a/media-libs/glfw/glfw-3.3.4-r1.ebuild b/media-libs/glfw/glfw-3.3.4-r1.ebuild
index 43f33ee0dd73..1cf0a04e0032 100644
--- a/media-libs/glfw/glfw-3.3.4-r1.ebuild
+++ b/media-libs/glfw/glfw-3.3.4-r1.ebuild
@@ -13,11 +13,11 @@ SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
-IUSE="wayland"
+IUSE="wayland-only"
RDEPEND="
x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
- !wayland? (
+ !wayland-only? (
virtual/opengl[${MULTILIB_USEDEP}]
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXcursor[${MULTILIB_USEDEP}]
@@ -25,21 +25,21 @@ RDEPEND="
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
)
- wayland? (
+ wayland-only? (
dev-libs/wayland[${MULTILIB_USEDEP}]
media-libs/mesa[egl,wayland,${MULTILIB_USEDEP}]
)
"
DEPEND="
${RDEPEND}
- !wayland? (
+ !wayland-only? (
x11-base/xorg-proto
x11-libs/libXi[${MULTILIB_USEDEP}]
)
- wayland? ( dev-libs/wayland-protocols )
+ wayland-only? ( dev-libs/wayland-protocols )
"
BDEPEND="
- wayland? (
+ wayland-only? (
dev-util/wayland-scanner
kde-frameworks/extra-cmake-modules
)
@@ -48,7 +48,7 @@ BDEPEND="
src_configure() {
local mycmakeargs=(
-DGLFW_BUILD_EXAMPLES=no
- -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DGLFW_USE_WAYLAND="$(usex wayland-only wayland)"
-DBUILD_SHARED_LIBS=1
)
cmake-multilib_src_configure
diff --git a/media-libs/glfw/metadata.xml b/media-libs/glfw/metadata.xml
index 6e5bbe581196..cd68a68804a2 100644
--- a/media-libs/glfw/metadata.xml
+++ b/media-libs/glfw/metadata.xml
@@ -9,4 +9,7 @@
<remote-id type="github">glfw/glfw</remote-id>
<changelog>https://www.glfw.org/changelog.html</changelog>
</upstream>
+ <use>
+ <flag name="wayland-only">Enable wayland support and disable X11 support</flag>
+ </use>
</pkgmetadata>