summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-12-18 20:50:14 -0300
committerPacho Ramos <pacho@gentoo.org>2023-12-20 11:23:01 +0100
commit3952d8aa8b6d91b1a246524028c2367dba35d6d4 (patch)
tree0032a1ed5d4e4771f37e7e34baf5d19d9cea9b54
parentnet-misc/nextcloud-client: add 3.11.0 (diff)
downloadgentoo-3952d8aa8b6d91b1a246524028c2367dba35d6d4.tar.gz
gentoo-3952d8aa8b6d91b1a246524028c2367dba35d6d4.tar.bz2
gentoo-3952d8aa8b6d91b1a246524028c2367dba35d6d4.zip
app-office/planner: Version bump to 0.14.92
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34357 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--app-office/planner/Manifest1
-rw-r--r--app-office/planner/planner-0.14.92.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-office/planner/Manifest b/app-office/planner/Manifest
index 86d2cf5d35c4..6fff097406ad 100644
--- a/app-office/planner/Manifest
+++ b/app-office/planner/Manifest
@@ -1 +1,2 @@
DIST planner-0.14.91.tar.xz 3887084 BLAKE2B 7719ead3f9794aa29ec67f8bfd9e3d7b7541d79542befe767c2f41381a9c62493790df314e940731cf5deefb6ac4dcece67623fc5ae8d8b792b0c95793682b39 SHA512 579ad60d3282124f9cf954163c27feaa1d505ce3135b3d668e1fe0ca036d7e7290bbd3a6d9c30f32a77594c5d60988feee670266c34c0a8b9240510609ab46e2
+DIST planner-0.14.92.tar.xz 3888436 BLAKE2B 5fde169da3787bdebbd0d49448b602a904a3cb6b1fed3047ef76162b070d2ab1f0793da591936ac8f10c8951cba86185d2b3ac580aeeb2a61595ab6b1814e560 SHA512 35f0ea6bb04937c164c42082db717962eba6e0353a4750d3213cb7a0e93b8649c99c52060c95c4c6037b6c7019f90161b3c531d5e75eabe453d0fad50c887f27
diff --git a/app-office/planner/planner-0.14.92.ebuild b/app-office/planner/planner-0.14.92.ebuild
new file mode 100644
index 000000000000..cc69f0dfc406
--- /dev/null
+++ b/app-office/planner/planner-0.14.92.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Planner"
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/World/planner.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+SLOT="0"
+LICENSE="GPL-2+"
+IUSE="examples libgda"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=x11-libs/gtk+-3.22:3
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ libgda? ( >=gnome-extra/libgda-1.0:5 )
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libgda database-gda)
+ -Deds=disabled # Doesn't provide much value, not very tested
+ $(meson_use examples)
+ -Dgtk_doc=false # Only for a private library
+ -Dsimple-priority-scheduling=false # experimental
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use examples; then
+ mv "${ED}"/usr/share/doc/planner "${ED}"/usr/share/doc/${PF} || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}