summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-26 21:49:24 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-26 21:49:24 -0700
commit3958083a58a01a0d5f5955487f51c3a312df0193 (patch)
treee6f50a2f2516c104be6d01517ed202bc1132d3f3
parentnet-im/telepathy-mission-control: Depend on python[xml] (diff)
downloadgentoo-3958083a.tar.gz
gentoo-3958083a.tar.bz2
gentoo-3958083a.zip
gnome-extra/yelp: Version bump to 42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/yelp-42.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index b9f622ae5c31..2594e94e945c 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1,2 +1,3 @@
DIST yelp-41.2.tar.xz 1531228 BLAKE2B 310bb73b8b841ed72e40530fe7d94fa2b223003fea40530cddb774cff059ce47cb613693ff3e45d2e9fb6beb2130c30d8d0b760e61c749b5d7e02143d17c2efd SHA512 171020b258531d26d1ab6193222b1b31bbde0be7da87524911e38143a606f38b29f9d76cb600cffc71da63d81274f656c426e79101acfa64caaf29e1a44020bf
DIST yelp-42.0.tar.xz 1512792 BLAKE2B f8a24849e9fd2d4fb5e10bb4449ddded77e2548313546308c69189fc07216e090f1a0a28090537477b20a039f8891374465ef3c585d2196febfc73e9e5dfae5c SHA512 3e2ce7436145d290eb67f39935f8351cafa316c1fc96e41fa316deb4e5f29582b1b224f308e4e22bf2590755286f8a927c5bc988633e14f7d10f0de2d62f962c
+DIST yelp-42.1.tar.xz 1512620 BLAKE2B a0ba02a560c19e516c42f77a34f3296dd6dd9d3dba9b34b2243a2c7689b7117cd82dea8e169ec7001ba15860c74f1c7ace061094516391b38f5054b566e613b2 SHA512 3c8150503e828c8d2994b7af6f7c673b696b01f4a82abcbbc0395909a0e0eb2d64a9e445a5b1683a0c9aa0abc7040cc563917e55b126879ce7c4dda117bbf3db
diff --git a/gnome-extra/yelp/yelp-42.1.ebuild b/gnome-extra/yelp/yelp-42.1.ebuild
new file mode 100644
index 000000000000..db120a9de577
--- /dev/null
+++ b/gnome-extra/yelp/yelp-42.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.67.4:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-41.0
+ >=net-libs/webkit-gtk-2.19.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ >=gui-libs/libhandy-1.5.0:1
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.13
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch # needs eautoreconf
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-webkit2gtk-4-0 \
+ --enable-bz2 \
+ --enable-lzma \
+ APPSTREAM_UTIL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}