summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-04-29 07:27:31 +0200
committerHans de Graaff <graaff@gentoo.org>2021-04-30 07:52:07 +0200
commit3987c4285d7e497d1b9f484ae470db10df7ce6ec (patch)
treecf70f8db11f8ef526babd98567f10fb81f1e449e
parentdev-ruby/rbnacl: add ruby30 (diff)
downloadgentoo-3987c428.tar.gz
gentoo-3987c428.tar.bz2
gentoo-3987c428.zip
dev-ruby/webmock: cleanup
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/webmock/Manifest2
-rw-r--r--dev-ruby/webmock/webmock-3.11.0.ebuild65
-rw-r--r--dev-ruby/webmock/webmock-3.11.2.ebuild69
3 files changed, 0 insertions, 136 deletions
diff --git a/dev-ruby/webmock/Manifest b/dev-ruby/webmock/Manifest
index d27b77328973..a9c2250ae697 100644
--- a/dev-ruby/webmock/Manifest
+++ b/dev-ruby/webmock/Manifest
@@ -1,5 +1,3 @@
-DIST webmock-3.11.0.gem 125440 BLAKE2B 8c57ca5b49922a61590595cdeeb5d3306edb3be616fd8e5c68617838831537f2106664201580f645de58322f11e684dfc8404d91139eaead5810c0cb40d5dc1f SHA512 dda7318d32dd88dcd4bc1fee9d1f4644f272348b532cbb59afde2e6a1fc42f359125b28d605ff1a18edac4ed71c00aceb1c67a364c15cfa56092e226588b449c
-DIST webmock-3.11.2.gem 125440 BLAKE2B a0a3bd2294ccfd5a360736edbd70fcb3a2734048dca933798502f07583f8b08a0d5aa5e25d4b0e262ada82e0bf9d1fccc28b932e0648180922db402a84f6f101 SHA512 757e2c19853b7e7a934cc308970ec4a2174df3592ed1eb1e1b7e1fce9cfb99720d826bad069f821d8271a7b5b04ec4f30009d124ae86b2a93604c1bc24f9f65d
DIST webmock-3.11.3.gem 125952 BLAKE2B 664253079457cdf400be869b9e61092b12872282057540e42e6fb73a5fbaa38666757f7f8bd336e4f5c45ea1ec52f9af4b444ba67ae24db62a75b5c18636ae08 SHA512 80fd2139126e1e9d6907dfe93021d77179ae6c31cc2a63eb3ee47c011c2a48f18bb84ac08322da8def014f2293564f5669eb41037edbe72ffccfefb7ea281739
DIST webmock-3.7.6.gem 122368 BLAKE2B 9bc40971f1eec96d88217544acc67b7abfe6c0815a0696119e12fc5629b4f51e1164ecc982525d2c02fa50c7b1b09548c4831c1d597f06acde04a83227ba0dc9 SHA512 85455495476b22d94b23e34a92db3f0f8cf1aa5bb52ea6a8eb71f5f0bcbdad1edc13dff778c62806ec27850320e9f4e17f12525bbac552e5e105ee1ecd771efd
DIST webmock-3.8.3.gem 122880 BLAKE2B 66371028294f3b15172d718e0fa9402ad6ed1bf7beedb0c62621ad31758d25e401af9cd982a6f29cd1161a7e4d7954f6f9df22ab2e0c44c970a0edca3c0f1304 SHA512 6c845c4ed0c82ba4bb1f32d0d87a87eb945c54e159317aa14e2238b497d38282b7e81542e78c0d68d4b8d4a08e46137de84503829b7381e6d945e45474ebb507
diff --git a/dev-ruby/webmock/webmock-3.11.0.ebuild b/dev-ruby/webmock/webmock-3.11.0.ebuild
deleted file mode 100644
index d220117eb5cf..000000000000
--- a/dev-ruby/webmock/webmock-3.11.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.3.6
- >=dev-ruby/crack-0.3.2
- >=dev-ruby/hashdiff-0.4.0:0
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
- >=dev-ruby/httpclient-2.8.0
- || ( dev-ruby/http:4 dev-ruby/http:3 ) )"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/d' spec/spec_helper.rb || die
- rm spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
-
- # Avoid httpclient specs that require network access, most likely
- # because mocking does not fully work.
- sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
- -e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
- spec/acceptance/httpclient/httpclient_spec.rb
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}
diff --git a/dev-ruby/webmock/webmock-3.11.2.ebuild b/dev-ruby/webmock/webmock-3.11.2.ebuild
deleted file mode 100644
index 0b2512f21dfb..000000000000
--- a/dev-ruby/webmock/webmock-3.11.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.3.6
- >=dev-ruby/crack-0.3.2
- >=dev-ruby/hashdiff-0.4.0:0
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
- >=dev-ruby/httpclient-2.8.0
-)"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
-
- # Drop tests for dev-ruby/http for now since this package only works with ruby26
- sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/http_rb/* || die
-
- # Avoid httpclient specs that require network access, most likely
- # because mocking does not fully work.
- sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
- -e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
- spec/acceptance/httpclient/httpclient_spec.rb
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}