summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:23:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:44:19 +0200
commit398d626c2bcff5d05db5b24b4dc3902154c78726 (patch)
tree9eee0bfe8956d3951f96d0a497533d6f814f8363
parentkde-frameworks/ktextwidgets: 5.81.0 version bump (diff)
downloadgentoo-398d626c2bcff5d05db5b24b4dc3902154c78726.tar.gz
gentoo-398d626c2bcff5d05db5b24b4dc3902154c78726.tar.bz2
gentoo-398d626c2bcff5d05db5b24b4dc3902154c78726.zip
kde-frameworks/kwallet: 5.81.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.81.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 84f4ff3f9d2e..9caee7b51352 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.77.0.tar.xz 299936 BLAKE2B a9e4f773feab5532fade0c3a5d75131a7890bd45c1d948ffcbe4f3a46fc9adb213805d8ecc1b96445da55b1b7b2628abd0f4b5ae5af69dfe98474c4951a601a4 SHA512 761206a9aedc64b30e9f47666f9b703d4db28f68ede7b2576ee23397c41dd875f51bc7444d29fc0e5e137c517b4158fa435d111559f9156183615897abf5fca4
DIST kwallet-5.80.0.tar.xz 300100 BLAKE2B 3f192acc7c432cb426dbfe9d83a409ca7da5974451ce185ec583761695b104f6a95414e43fe56d69fcbaf0d3f777b46b9700b1678fe72d509d0116064a49e3b6 SHA512 e815210f7c0911e849b0242ba239e4f5a2c95dc39af5a03cfb68abea1b2be26c81aa474678749064179cf6311f2710cc94c634e3acfc1ca6661789bd6ba4d33f
+DIST kwallet-5.81.0.tar.xz 300876 BLAKE2B 615bccbdb9a4a258b6d9111d213f64d0a97cc54388401e6b2509298ee1d3a94a951d7d7507b064e32fe18bedd7e16267db9f38fb2c4e675fb94a51c9edb56f23 SHA512 6f967526e3bbc48109dc175d6d95115a09319358a77a0fa4b4398ce9f3582f0dacfa94237bd0d64e5975d6b1aa195204532eb619bd07c985af0595253c6caedc
diff --git a/kde-frameworks/kwallet/kwallet-5.81.0.ebuild b/kde-frameworks/kwallet/kwallet-5.81.0.ebuild
new file mode 100644
index 000000000000..6958775bab35
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.81.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}